gdb: add microblaze internal toolchain
authorSpenser Gilliland <spenser@gillilanding.com>
Thu, 5 Dec 2013 17:20:55 +0000 (18:20 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 6 Dec 2013 21:46:30 +0000 (22:46 +0100)
Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gdb/Config.in.host
package/gdb/gdb.mk

index 074aa571e03b529a57c7f0e56ff1155b407f66d3..de0e0be290c3ce14df691f553400cc1b619698ba 100644 (file)
@@ -16,6 +16,7 @@ if BR2_PACKAGE_HOST_GDB
 choice
        prompt "GDB debugger Version"
        depends on !BR2_arc
+       depends on !BR2_microblaze
        default BR2_GDB_VERSION_6_6 if BR2_bfin
        default BR2_GDB_VERSION_6_7_1_AVR32_2_1_5 if BR2_avr32
        default BR2_GDB_VERSION_7_5
@@ -59,5 +60,6 @@ config BR2_GDB_VERSION
        default "7.4.1"    if BR2_GDB_VERSION_7_4
        default "7.5.1"    if BR2_GDB_VERSION_7_5
        default "f25a1952afd054205f9471e449c1f7ca5b271b7c" if BR2_arc
+       default "6be65fb56ea6694a9260733a536a023a1e2d4d57" if BR2_microblaze
 
 endif
index e6b1115e236baf025cbd36ea5076675d01fd229c..fbe16411388a270abf032ae7409cc4d19ad757f5 100644 (file)
@@ -26,6 +26,11 @@ GDB_SITE = $(call github,foss-for-synopsys-dwc-arc-processors,gdb,$(GDB_VERSION)
 GDB_SOURCE = gdb-$(GDB_VERSION).tar.gz
 endif
 
+ifeq ($(BR2_microblaze),y)
+GDB_SITE = $(call github,Xilinx,gdb,$(GDB_VERSION))
+GDB_SOURCE = gdb-$(GDB_VERSION).tar.gz
+endif
+
 ifeq ($(GDB_VERSION),6.7.1-avr32-2.1.5)
 GDB_SITE = ftp://www.at91.com/pub/buildroot/
 endif