package/ffmpeg: disable asm on mips r6
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 7 Apr 2019 07:58:16 +0000 (09:58 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 7 Apr 2019 08:44:48 +0000 (10:44 +0200)
Fixes:
 - http://autobuild.buildroot.org/results/f5125bde6d3604af3342a205a8445947aff95d5a
 - http://autobuild.buildroot.org/results/beb70bd6c1dd9abf7bc1b53299ba0094a36f4179

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ffmpeg/ffmpeg.mk

index 17e4fa70748ded4267f45bdf082f7ee097b0744b..eb237d35237d849675f825de3b0fa18ac6d23add 100644 (file)
@@ -482,6 +482,11 @@ FFMPEG_CONF_OPTS += --disable-mipsfpu
 else
 FFMPEG_CONF_OPTS += --enable-mipsfpu
 endif
+
+# Fix build failure on "addi opcode not supported"
+ifeq ($(BR2_mips_32r6)$(BR2_mips_64r6),y)
+FFMPEG_CONF_OPTS += --disable-asm
+endif
 endif # MIPS
 
 ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)