package/perl-http-negotiate: New package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 19 Apr 2015 10:17:10 +0000 (12:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Apr 2015 11:43:45 +0000 (13:43 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/perl-http-negotiate/Config.in [new file with mode: 0644]
package/perl-http-negotiate/perl-http-negotiate.hash [new file with mode: 0644]
package/perl-http-negotiate/perl-http-negotiate.mk [new file with mode: 0644]

index c1daa7391109a21833ea0b80bfc96f45dbd79799..0066da9f1e91a388e86b3ef12099694bbe1d479c 100644 (file)
@@ -516,6 +516,7 @@ menu "Perl libraries/modules"
        source "package/perl-http-daemon/Config.in"
        source "package/perl-http-date/Config.in"
        source "package/perl-http-message/Config.in"
+       source "package/perl-http-negotiate/Config.in"
        source "package/perl-io-html/Config.in"
        source "package/perl-io-socket-ssl/Config.in"
        source "package/perl-json-tiny/Config.in"
diff --git a/package/perl-http-negotiate/Config.in b/package/perl-http-negotiate/Config.in
new file mode 100644 (file)
index 0000000..2b7f7b9
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PERL_HTTP_NEGOTIATE
+       bool "perl-http-negotiate"
+       select BR2_PACKAGE_PERL_HTTP_MESSAGE
+       help
+         This module provides a complete implementation of the HTTP content
+         negotiation algorithm specified in draft-ietf-http-v11-spec-00.ps
+         chapter 12.
+
+         http://github.com/gisle/http-negotiate
diff --git a/package/perl-http-negotiate/perl-http-negotiate.hash b/package/perl-http-negotiate/perl-http-negotiate.hash
new file mode 100644 (file)
index 0000000..f1db2ff
--- /dev/null
@@ -0,0 +1,3 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    1236195250e264d7436e7bb02031671b HTTP-Negotiate-6.01.tar.gz
+sha256 1c729c1ea63100e878405cda7d66f9adfd3ed4f1d6cacaca0ee9152df728e016 HTTP-Negotiate-6.01.tar.gz
diff --git a/package/perl-http-negotiate/perl-http-negotiate.mk b/package/perl-http-negotiate/perl-http-negotiate.mk
new file mode 100644 (file)
index 0000000..569ed2b
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-http-negotiate
+#
+################################################################################
+
+PERL_HTTP_NEGOTIATE_VERSION = 6.01
+PERL_HTTP_NEGOTIATE_SOURCE = HTTP-Negotiate-$(PERL_HTTP_NEGOTIATE_VERSION).tar.gz
+PERL_HTTP_NEGOTIATE_SITE = $(BR2_CPAN_MIRROR)/authors/id/G/GA/GAAS
+PERL_HTTP_NEGOTIATE_DEPENDENCIES = perl-http-message
+PERL_HTTP_NEGOTIATE_LICENSE = Artistic or GPLv1+
+PERL_HTTP_NEGOTIATE_LICENSE_FILES = README
+
+$(eval $(perl-package))