package/kodi-visualisation-spectrum: bump version to 3.0.2-Leia
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 19 Jan 2020 11:07:32 +0000 (12:07 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 23 Jan 2020 00:04:03 +0000 (01:04 +0100)
Added patch to fix cstddef include and license hash.

Repo was moved to the xbmc project:
https://github.com/xbmc/repo-binary-addons/commit/89d0272e881557fd82bf5897d3d4fbc1123af46a

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/kodi-visualisation-spectrum/0001-Backport-Add-missing-cstddef-include.patch [new file with mode: 0644]
package/kodi-visualisation-spectrum/kodi-visualisation-spectrum.hash
package/kodi-visualisation-spectrum/kodi-visualisation-spectrum.mk

diff --git a/package/kodi-visualisation-spectrum/0001-Backport-Add-missing-cstddef-include.patch b/package/kodi-visualisation-spectrum/0001-Backport-Add-missing-cstddef-include.patch
new file mode 100644 (file)
index 0000000..5b1bb0c
--- /dev/null
@@ -0,0 +1,30 @@
+From b2c54c1043c2396678005b578e85db30bdf5ccb9 Mon Sep 17 00:00:00 2001
+From: Bernd Kuhls <bernd.kuhls@t-online.de>
+Date: Sat, 18 Jan 2020 20:22:41 +0100
+Subject: [PATCH] [Backport] Add missing cstddef include
+
+Backported from https://github.com/xbmc/visualization.spectrum/pull/37
+
+Patch sent upstream:
+https://github.com/xbmc/visualization.spectrum/pull/38
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+---
+ src/opengl_spectrum.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/opengl_spectrum.cpp b/src/opengl_spectrum.cpp
+index 05409ea..2441fd6 100644
+--- a/src/opengl_spectrum.cpp
++++ b/src/opengl_spectrum.cpp
+@@ -38,6 +38,7 @@
+ #include <string.h>
+ #include <math.h>
+ #include <stdint.h>
++#include <cstddef>
+ #include <glm/glm.hpp>
+ #include <glm/gtc/type_ptr.hpp>
+-- 
+2.20.1
+
index 2d9ab0f3cf9ef3c64dd1ec69dcf9ce44c47e75fb..4064184a75724d4525f4cd9a5864b6a7762d75b8 100644 (file)
@@ -1,2 +1,3 @@
 # Locally computed
-sha256 7ee78ff5c24e3f81b6e2a9208237f34667cb9faa5453d7bdb900ab65245973f1  kodi-visualisation-spectrum-1.1.1.tar.gz
+sha256 ec88defbb90fdb03f075abdba39c436906a8fbad8f034da3e3b31f75842206cc  kodi-visualisation-spectrum-3.0.2-Leia.tar.gz
+sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  COPYING
index 016f405e40e0c1040476fc27c23281dc1a336a1d..c3d61c1ef478e676304035990b3cc880ca7b79f2 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-KODI_VISUALISATION_SPECTRUM_VERSION = 1.1.1
-KODI_VISUALISATION_SPECTRUM_SITE = $(call github,notspiff,visualization.spectrum,v$(KODI_VISUALISATION_SPECTRUM_VERSION))
+KODI_VISUALISATION_SPECTRUM_VERSION = 3.0.2-Leia
+KODI_VISUALISATION_SPECTRUM_SITE = $(call github,xbmc,visualization.spectrum,$(KODI_VISUALISATION_SPECTRUM_VERSION))
 KODI_VISUALISATION_SPECTRUM_LICENSE = GPL-2.0+
 KODI_VISUALISATION_SPECTRUM_LICENSE_FILES = COPYING
 KODI_VISUALISATION_SPECTRUM_DEPENDENCIES = kodi