zlib: fix headers installation in target directory
authorLionel Landwerlin <llandwerlin@gmail.com>
Wed, 27 Jan 2010 01:08:49 +0000 (02:08 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 28 Jan 2010 20:48:40 +0000 (21:48 +0100)
Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/zlib/zlib.mk

diff --git a/CHANGES b/CHANGES
index 578543b19a1858d295def8469fbd7febde8ff59e..97c55018acc375ca55d27e21617897e25941f905 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -10,7 +10,7 @@
        libglib2, libpcap, libungif, libxml2, lighttpd, mesa, mpg123,
        mtd-utils, neon, netstat-nat, openvpn, pcre, qt, rpm, sawman, sdl,
        sdl_ttf, ser2net, sqlite, sshfs, tremor, u-boot, usb_modeswitch,
-       usbutils, webkit, wpa_supplicant, xfsprogs
+       usbutils, webkit, wpa_supplicant, xfsprogs, zlib
 
        Issues resolved (http://bugs.uclibc.org):
 
@@ -94,7 +94,7 @@
        shared-mime-info, sfdisk, spawn-fcgi, speech-tools, sqlite, squashfs,
        synergy, syslinux, sysklogd, target-binutils, tcpdump, torsmo, u-boot,
        udpcast, util-linux, valgrind, vsftpd, wipe, wpa-supplicant, x11vnc,
-       xdata_xcursor-themes, xboard, xfsprogs, xstroke, zlib
+       xdata_xcursor-themes, xboard, xfsprogs, xstroke, zlib[5~
 
        Removed package: mdnsresponder, mpatrol, gcc 3.4.6 + 4.0.4, vice
 
index 5365b30efbdc682346687b63c25caf5700f820c0..743247309a942d856efa56e0ccc0547e473a235c 100644 (file)
@@ -43,8 +43,8 @@ endef
 
 ifeq ($(BR2_HAVE_DEVFILES),y)
 define ZLIB_INSTALL_TARGET_HEADERS
-       $(INSTALL) -D $(@D)/zlib.h $(STAGING_DIR)/usr/include/zlib.h
-       $(INSTALL) $(@D)/zconf.h $(STAGING_DIR)/usr/include/
+       $(INSTALL) -D $(@D)/zlib.h $(TARGET_DIR)/usr/include/zlib.h
+       $(INSTALL) $(@D)/zconf.h $(TARGET_DIR)/usr/include/
 endef
 endif