samba4: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 10:35:08 +0000 (12:35 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:35:41 +0000 (01:35 +0200)
This commit switches to use the new gettext logic, which involves
using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
on gettext/host-gettext.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/samba4/samba4.mk

index 93c45daa5837a594c11594d9d983daa48610f467..86546e975b65c8bed34d9a36bc56d38ee67c2d86 100644 (file)
@@ -15,7 +15,8 @@ SAMBA4_DEPENDENCIES = \
        e2fsprogs popt python zlib \
        $(if $(BR2_PACKAGE_LIBAIO),libaio) \
        $(if $(BR2_PACKAGE_LIBCAP),libcap) \
-       $(if $(BR2_PACKAGE_READLINE),readline)
+       $(if $(BR2_PACKAGE_READLINE),readline) \
+       $(TARGET_NLS_DEPENDENCIES)
 
 ifeq ($(BR2_PACKAGE_ACL),y)
 SAMBA4_CONF_OPTS += --with-acl-support
@@ -46,12 +47,6 @@ else
 SAMBA4_CONF_OPTS += --without-fam
 endif
 
-ifeq ($(BR2_PACKAGE_GETTEXT),y)
-SAMBA4_DEPENDENCIES += gettext
-else
-SAMBA4_CONF_OPTS += --without-gettext
-endif
-
 ifeq ($(BR2_PACKAGE_GNUTLS),y)
 SAMBA4_CONF_OPTS += --enable-gnutls
 SAMBA4_DEPENDENCIES += gnutls