package/lensfun: new package
authorRomain Naour <romain.naour@gmail.com>
Sun, 5 Mar 2017 15:09:56 +0000 (16:09 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 28 Mar 2017 20:47:38 +0000 (22:47 +0200)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Jeremy Rosen <jeremy.rosen@enst-bretagne.fr>
[Thomas: add missing select BR2_PACKAGE_LIBGLIB2, noticed by Baruch.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/lensfun/Config.in [new file with mode: 0644]
package/lensfun/lensfun.hash [new file with mode: 0644]
package/lensfun/lensfun.mk [new file with mode: 0644]

index 215a3b474f548d1bca5e5adef08170152942a3cb..9c6dae8a0b99130ccbdc91c55ffeaaa5b3c9dc1f 100644 (file)
@@ -1319,6 +1319,7 @@ F:        package/enlightenment/
 F:     package/expedite/
 F:     package/iqvlinux/
 F:     package/liblinear/
+F:     package/lensfun/
 F:     package/linux-syscall-support/
 F:     package/lugaru/
 F:     package/mcelog/
index 9a78e0aa036ec4fd4556546998a758de3f095272..24c8a0877d2146e58ae18b59cb5becdde73f200d 100644 (file)
@@ -1015,6 +1015,7 @@ menu "Graphics"
        source "package/jpeg/Config.in"
        source "package/kmsxx/Config.in"
        source "package/lcms2/Config.in"
+       source "package/lensfun/Config.in"
        source "package/leptonica/Config.in"
        source "package/lesstif/Config.in"
        source "package/libart/Config.in"
diff --git a/package/lensfun/Config.in b/package/lensfun/Config.in
new file mode 100644 (file)
index 0000000..7ec4902
--- /dev/null
@@ -0,0 +1,29 @@
+config BR2_PACKAGE_LENSFUN
+       bool "lensfun"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_USE_WCHAR # libglib2
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+       depends on BR2_USE_MMU # libglib2
+       select BR2_PACKAGE_LIBGLIB2
+       help
+         Lensfun itself is only a library for correcting several
+         artefacts and a database for storing lens profiles. To
+         actually use Lensfun to process your images you need an
+         image editing application with Lensfun support.
+
+         http://lensfun.sourceforge.net
+
+if BR2_PACKAGE_LENSFUN
+
+config BR2_PACKAGE_LENSFUN_TOOLS
+       bool "lensfun tools"
+       select BR2_PACKAGE_LIBPNG
+       help
+         Build 'lenstool'.
+
+endif
+
+comment "lensfun needs a toolchain w/ C++, threads, wchar"
+       depends on BR2_USE_MMU
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS \
+               || !BR2_USE_WCHAR
diff --git a/package/lensfun/lensfun.hash b/package/lensfun/lensfun.hash
new file mode 100644 (file)
index 0000000..a60f8f4
--- /dev/null
@@ -0,0 +1,5 @@
+# From https://sourceforge.net/projects/lensfun/files/0.3.2
+sha1 1d978b15aa7304d66a4931fa37ca9f8f89396c16 lensfun-0.3.2.tar.gz
+md5 247e59a0812ec451f6cd0d20b3379cb5 lensfun-0.3.2.tar.gz
+# Locally calculated
+sha256 ae8bcad46614ca47f5bda65b00af4a257a9564a61725df9c74cb260da544d331 lensfun-0.3.2.tar.gz
diff --git a/package/lensfun/lensfun.mk b/package/lensfun/lensfun.mk
new file mode 100644 (file)
index 0000000..8e92e59
--- /dev/null
@@ -0,0 +1,41 @@
+################################################################################
+#
+# lensfun
+#
+################################################################################
+
+LENSFUN_VERSION = 0.3.2
+LENSFUN_SITE = https://sourceforge.net/projects/lensfun/files/$(LENSFUN_VERSION)
+LENSFUN_LICENSE = LGPLv3+ (libraries), GPLv3+ (programs)
+LENSFUN_LICENSE_FILES = docs/gpl-3.0.txt docs/lgpl-3.0.txt
+LENSFUN_INSTALL_STAGING = YES
+LENSFUN_DEPENDENCIES = libglib2
+
+# lensfun doesn't support in source build, it fail to build lensfun tools.
+LENSFUN_SUPPORTS_IN_SOURCE_BUILD = NO
+
+ifeq ($(BR2_X86_CPU_HAS_SSE),y)
+LENSFUN_CONF_OPTS += -DBUILD_FOR_SSE=ON
+else
+LENSFUN_CONF_OPTS += -DBUILD_FOR_SSE=OFF
+endif
+
+ifeq ($(BR2_X86_CPU_HAS_SSE2),y)
+LENSFUN_CONF_OPTS += -DBUILD_FOR_SSE2=ON
+else
+LENSFUN_CONF_OPTS += -DBUILD_FOR_SSE2=OFF
+endif
+
+ifeq ($(BR2_PACKAGE_LENSFUN_TOOLS),y)
+LENSFUN_DEPENDENCIES += libpng
+LENSFUN_CONF_OPTS += -DBUILD_LENSTOOL=ON
+# broken
+else
+LENSFUN_CONF_OPTS += -DBUILD_LENSTOOL=OFF
+endif
+
+# Don't install helper scripts (which require python3 and gksudo).
+# Don't run setup.py on the host.
+LENSFUN_CONF_OPTS += -DINSTALL_HELPER_SCRIPTS=OFF -DPYTHON=OFF
+
+$(eval $(cmake-package))