flashrom: Bump to version 0.9.8
authorflorent valette <florent.valette@gmail.com>
Sun, 17 May 2015 08:16:24 +0000 (10:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 21 May 2015 21:06:20 +0000 (23:06 +0200)
This version adds support for new Intel SoC (e.g. BayTrail) and
spi over usb devices such as pickit2 and ftdi usb-spi.

[Thomas:
  - add missing Config.in comment about the thread dependency
  - remove 'Requires PCIUtils libraries' from the Config.in help text,
    since flashrom now requires more than PCIUtils library, and we
    typically don't document such dependencies in Config.in help
    texts.]

Signed-off-by: Florent Valette <florent.valette@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/flashrom/Config.in
package/flashrom/flashrom.mk

index 956500f0a478cc9dac1dd2a23d3610537db39372..17a041619e7c4a2801053659ff4e6ab7ced12277 100644 (file)
@@ -1,11 +1,20 @@
 config BR2_PACKAGE_FLASHROM
        bool "flashrom"
        select BR2_PACKAGE_PCIUTILS
+       select BR2_PACKAGE_LIBUSB
+       select BR2_PACKAGE_LIBUSB_COMPAT
+       select BR2_PACKAGE_LIBFTDI
        # dmidecode is only a runtime dependency
        select BR2_PACKAGE_DMIDECODE
        depends on BR2_i386 || BR2_x86_64
+       depends on BR2_TOOLCHAIN_HAS_THREADS    # libusb
+       depends on BR2_ARCH_HAS_ATOMICS         # libftdi
        help
          BIOS-updating utility.
-         Requires PCIUtils libraries.
 
          http://flashrom.org/
+
+comment "flashrom needs a toolchain w/ threads"
+       depends on BR2_i386 || BR2_x86_64
+       depends on BR2_ARCH_HAS_ATOMICS
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
index 70bbe307becfe658ab96a37d3b2e1b191ff970c8..525470aeffa3ff1fece3df6091d0cc7ea92b1d5f 100644 (file)
@@ -4,10 +4,10 @@
 #
 ################################################################################
 
-FLASHROM_VERSION = 0.9.7
+FLASHROM_VERSION = 0.9.8
 FLASHROM_SOURCE = flashrom-$(FLASHROM_VERSION).tar.bz2
 FLASHROM_SITE = http://download.flashrom.org/releases
-FLASHROM_DEPENDENCIES = pciutils
+FLASHROM_DEPENDENCIES = pciutils libusb libusb-compat libftdi
 FLASHROM_LICENSE = GPLv2+
 FLASHROM_LICENSE_FILES = COPYING