Makefile.autotools.in: honor CONFIG_SHELL and TAR.
authorWade Berrier <wberrier@gmail.com>
Tue, 7 Oct 2008 17:08:27 +0000 (17:08 -0000)
committerWade Berrier <wberrier@gmail.com>
Tue, 7 Oct 2008 17:08:27 +0000 (17:08 -0000)
  Don't use recursively expanded definition
  (Use ':=' instead of '=')

package/Makefile.autotools.in

index 8294ebfa63fdb9aa75762fe0c240a60f8f094e4a..0760063005445e3849c3f42422b3a6f9d122d692 100644 (file)
@@ -125,7 +125,7 @@ TAR ?= tar
 #      ACLOCAL="$(ACLOCAL)"
 
 # Automatically detect tar --strip-path/components option
-TAR_STRIP_COMPONENTS = $(shell tar --help | grep strip-path > /dev/null ; if test $$? = 0 ; then echo '--strip-path' ; else echo '--strip-components' ; fi)
+TAR_STRIP_COMPONENTS := $(shell $(CONFIG_SHELL) -c '$(TAR) --help | grep strip-path > /dev/null ; if test $$? = 0 ; then echo '--strip-path' ; else echo '--strip-components' ; fi')
 
 ################################################################################
 # Implicit targets -- produce a stamp file for each step of a package build