package/gssdp: add optional dependency for gobject-introspection
authorAdam Duskett <Aduskett@gmail.com>
Sun, 15 Mar 2020 17:24:55 +0000 (10:24 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 22 Mar 2020 10:16:50 +0000 (11:16 +0100)
If gobject-introspection is selected, explicitly set -Dintrospection=true in
the configure options and add a dependency for gobject-introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/gssdp/gssdp.mk

index 071ad00109b23e49f7e210660be19fea74dc2919..bab3cbe0f78f93973c765dfc3c71c2a2bfc9da6b 100644 (file)
@@ -14,9 +14,15 @@ GSSDP_INSTALL_STAGING = YES
 GSSDP_DEPENDENCIES = host-pkgconf libglib2 libsoup
 GSSDP_CONF_OPTS = \
        -Dexamples=false \
-       -Dintrospection=false \
        -Dvapi=false
 
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+GSSDP_CONF_OPTS += -Dintrospection=true
+GSSDP_DEPENDENCIES += gobject-introspection
+else
+GSSDP_CONF_OPTS += -Dintrospection=false
+endif
+
 ifeq ($(BR2_PACKAGE_LIBGTK3),y)
 GSSDP_DEPENDENCIES += libgtk3
 GSSDP_CONF_OPTS += -Dsniffer=true