toolchain/uclibc: propagate mips mips32r2 variant setting to uclibc
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 12 Jan 2009 14:11:40 +0000 (14:11 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 12 Jan 2009 14:11:40 +0000 (14:11 -0000)
0.9.30 supports MIPS_ISA_MIPS32R2, so use it if mips32r2 variant is selected.

toolchain/uClibc/uclibc.mk

index 37409262d88449a2578ad3ddd6a3724852663f54..fe055cea1d0e744cb6db64594dcaa6583f98b44e 100644 (file)
@@ -185,6 +185,7 @@ ifeq ($(UCLIBC_TARGET_ARCH),mips)
         /bin/echo "# CONFIG_MIPS_ISA_3 is not set"; \
         /bin/echo "# CONFIG_MIPS_ISA_4 is not set"; \
         /bin/echo "# CONFIG_MIPS_ISA_MIPS32 is not set"; \
+        /bin/echo "# CONFIG_MIPS_ISA_MIPS32R2 is not set"; \
         /bin/echo "# CONFIG_MIPS_ISA_MIPS64 is not set"; \
        ) >> $(UCLIBC_DIR)/.oldconfig
 ifeq ($(BR2_MIPS_OABI),y)
@@ -209,10 +210,10 @@ ifeq ($(BR2_mips_4),y)
        $(SED) 's/.*\(CONFIG_MIPS_ISA_4\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
 endif
 ifeq ($(BR2_mips_32),y)
-       $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+       $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32\)[^R].*/\1=y/' $(UCLIBC_DIR)/.oldconfig
 endif
 ifeq ($(BR2_mips_32r2),y)
-       $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+       $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32R2\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
 endif
 ifeq ($(BR2_mips_64),y)
        $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS64\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig