package/sngrep: fix static linking against libpcap
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 29 Jan 2017 17:24:38 +0000 (18:24 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 6 Feb 2017 13:00:30 +0000 (14:00 +0100)
Inspired by
https://git.buildroot.net/buildroot/tree/package/aircrack-ng/aircrack-ng.mk#n30

Fixes
http://autobuild.buildroot.net/results/699/6993c398649469e25f2491fdb8f1ac9b6d6d8c3c/
http://autobuild.buildroot.net/results/846/8468df3462ac6d53faef228ca241bc500b2d7a52/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sngrep/sngrep.mk

index 52c8a2da4e0c1eec1568ee8fb9af607558da01a9..b82d8cefa7d711ec5215f19a774fd7308f918153 100644 (file)
@@ -11,6 +11,9 @@ SNGREP_LICENSE_FILES = LICENSE
 SNGREP_AUTORECONF = YES
 SNGREP_DEPENDENCIES = libpcap ncurses
 
+SNGREP_CONF_ENV += \
+       $(if $(BR2_STATIC_LIBS),LIBS="`$(STAGING_DIR)/usr/bin/pcap-config --static --libs`")
+
 # our ncurses wchar support is not properly detected
 SNGREP_CONF_OPTS += --disable-unicode