luabitop: New package
authorAssaf Inbal <shmuelzon@gmail.com>
Mon, 20 May 2013 12:56:38 +0000 (15:56 +0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 16 Jun 2013 20:02:14 +0000 (22:02 +0200)
Lua library for binary operations

[Peter: fix header, use TARGET_CONFIGURE_OPTS]
Signed-off-by: Assaf Inbal <shmuelzon@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/luabitop/Config.in [new file with mode: 0644]
package/luabitop/luabitop.mk [new file with mode: 0644]

index fa64426785905bd3c07cf99479efcfc67a6841d1..f218f65e5d5e6b431756551b66f8035267a7df79 100644 (file)
@@ -314,6 +314,7 @@ menu "LUA libraries/modules"
 source "package/cgilua/Config.in"
 source "package/copas/Config.in"
 source "package/coxpcall/Config.in"
+source "package/luabitop/Config.in"
 source "package/luacjson/Config.in"
 source "package/luaexpat/Config.in"
 source "package/luafilesystem/Config.in"
diff --git a/package/luabitop/Config.in b/package/luabitop/Config.in
new file mode 100644 (file)
index 0000000..83a85b1
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LUABITOP
+       bool "luabitop"
+       help
+         Lua BitOp is a C extension module for Lua 5.1/5.2 which adds bitwise
+         operations on numbers.
+
+         http://bitop.luajit.org
diff --git a/package/luabitop/luabitop.mk b/package/luabitop/luabitop.mk
new file mode 100644 (file)
index 0000000..c61e826
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# luabitop
+#
+################################################################################
+
+LUABITOP_VERSION = 1.0.2
+LUABITOP_SOURCE = LuaBitOp-$(LUABITOP_VERSION).tar.gz
+LUABITOP_SITE = http://bitop.luajit.org/download
+LUABITOP_LICENSE = MIT
+LUABITOP_LICENSE_FILES = README
+LUABITOP_DEPENDENCIES = lua
+
+define LUABITOP_BUILD_CMDS
+       $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
+endef
+
+define LUABITOP_INSTALL_TARGET_CMDS
+       mkdir -p $(TARGET_DIR)/usr/lib/lua
+       $(INSTALL) -p $(@D)/bit.so $(TARGET_DIR)/usr/lib/lua
+endef
+
+define LUABITOP_CLEAN_CMDS
+       $(MAKE) -C $(@D) clean
+endef
+
+$(eval $(generic-package))