pulseaudio: fix libsamplerate dependency
authorBaruch Siach <baruch@tkos.co.il>
Wed, 20 Dec 2017 16:02:51 +0000 (18:02 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 20 Dec 2017 20:37:18 +0000 (21:37 +0100)
The (deprecated) libsamplerate support is not enabled unless
--enable-samplerate is passed to configure. Fix this.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pulseaudio/pulseaudio.mk

index 3863557881e5c0492c1ade0b14c69aee8751dca0..13fcec52a3b3e0e179c672ce46a38e4e7cba226f 100644 (file)
@@ -17,7 +17,6 @@ PULSEAUDIO_CONF_OPTS = \
 
 PULSEAUDIO_DEPENDENCIES = \
        host-pkgconf libtool libsndfile speex host-intltool \
-       $(if $(BR2_PACKAGE_LIBSAMPLERATE),libsamplerate) \
        $(if $(BR2_PACKAGE_LIBGLIB2),libglib2) \
        $(if $(BR2_PACKAGE_AVAHI_DAEMON),avahi) \
        $(if $(BR2_PACKAGE_DBUS),dbus) \
@@ -25,6 +24,13 @@ PULSEAUDIO_DEPENDENCIES = \
        $(if $(BR2_PACKAGE_FFTW),fftw) \
        $(if $(BR2_PACKAGE_SYSTEMD),systemd)
 
+ifeq ($(BR2_PACKAGE_LIBSAMPLERATE),y)
+PULSEAUDIO_CONF_OPTS += --enable-samplerate
+PULSEAUDIO_DEPENDENCIES += libsamplerate
+else
+PULSEAUDIO_CONF_OPTS += --disable-samplerate
+endif
+
 ifeq ($(BR2_PACKAGE_GDBM),y)
 PULSEAUDIO_CONF_OPTS += --with-database=gdbm
 PULSEAUDIO_DEPENDENCIES += gdbm