libostree: add upstream patch to fix linking errors
authorMarcus Folkesson <marcus.folkesson@gmail.com>
Thu, 12 Jul 2018 05:55:15 +0000 (07:55 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 13 Jul 2018 08:08:58 +0000 (10:08 +0200)
Support for Avahi in libostree depends on some support functions from
libsoup.
Use its own support functions in case of libsoup is not provided.

Fixes:
  http://autobuild.buildroot.net/results/5e5441822e2a94f8de51bfa0470aced84720ce31

[Peter: enable AUTORECONF as .am file is touched]
Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libostree/0002-build-add-ostree-soup-to-build-process-when-configur.patch [new file with mode: 0644]
package/libostree/libostree.mk

diff --git a/package/libostree/0002-build-add-ostree-soup-to-build-process-when-configur.patch b/package/libostree/0002-build-add-ostree-soup-to-build-process-when-configur.patch
new file mode 100644 (file)
index 0000000..b89bd74
--- /dev/null
@@ -0,0 +1,45 @@
+From 1cd86d4978ad32405b41f864e11ac21a2474c2f3 Mon Sep 17 00:00:00 2001
+From: Marcus Folkesson <marcus.folkesson@gmail.com>
+Date: Tue, 3 Jul 2018 10:02:46 +0200
+Subject: [PATCH] build: add ostree-soup-* to build process when configured
+ with avahi
+
+Avoid getting these link errors:
+    ./.libs/libostree-1.so: undefined reference to `soup_uri_set_path'
+    ./.libs/libostree-1.so: undefined reference to `soup_uri_new'
+    ./.libs/libostree-1.so: undefined reference to `soup_uri_free'
+    ./.libs/libostree-1.so: undefined reference to `soup_uri_set_scheme'
+    ./.libs/libostree-1.so: undefined reference to `soup_uri_to_string'
+    ./.libs/libostree-1.so: undefined reference to `soup_uri_set_host'
+    ./.libs/libostree-1.so: undefined reference to `soup_uri_set_port'
+    collect2: error: ld returned 1 exit status
+
+Reproduce with:
+    ./configure --with-avahi --without-soup
+
+Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
+---
+ Makefile-libostree.am | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/Makefile-libostree.am b/Makefile-libostree.am
+index 01a209d1..dbc9ebb8 100644
+--- a/Makefile-libostree.am
++++ b/Makefile-libostree.am
+@@ -238,6 +238,13 @@ if USE_LIBSOUP
+ libostree_1_la_SOURCES += src/libostree/ostree-fetcher-soup.c
+ libostree_1_la_CFLAGS += $(OT_INTERNAL_SOUP_CFLAGS)
+ libostree_1_la_LIBADD += $(OT_INTERNAL_SOUP_LIBS)
++else
++if USE_AVAHI
++libostree_1_la_SOURCES += src/libostree/ostree-soup-uri.h \
++      src/libostree/ostree-soup-uri.c \
++      src/libostree/ostree-soup-form.c \
++      $(NULL)
++endif
+ endif
+ endif
+-- 
+2.18.0
+
index d9739b7901a1b0e7781dabe46d7c83eda5930bb1..69e84343e96d26cf7ea371a9db0d6a0a4ece5295 100644 (file)
@@ -12,6 +12,8 @@ LIBOSTREE_LICENSE = LGPL-2.0+
 LIBOSTREE_LICENSE_FILES = COPYING
 LIBOSTREE_DEPENDENCIES = e2fsprogs host-bison host-pkgconf libfuse libglib2 libgpgme xz
 LIBOSTREE_INSTALL_STAGING = YES
+# For 0002-build-add-ostree-soup-to-build-process-when-configur.patch
+LIBOSTREE_AUTORECONF = YES
 
 LIBOSTREE_CONF_OPTS += \
        --with-gpgme-prefix=$(STAGING_DIR)/usr \