mosquitto: supports only the real OpenSSL, not LibreSSL
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 16:48:42 +0000 (18:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 19:28:13 +0000 (21:28 +0200)
mosquitto will not build with LibreSSL without patches, so let's
support only OpenSSL.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mosquitto/mosquitto.mk

index c763f48ab1d573757dc0745fc44950f78348cc7f..c9b4418d044f876c47969f55e59b1a639be7a745 100644 (file)
@@ -30,8 +30,8 @@ else
 MOSQUITTO_MAKE_OPTS += WITH_THREADING=no
 endif
 
-ifeq ($(BR2_PACKAGE_OPENSSL),y)
-MOSQUITTO_DEPENDENCIES += openssl
+ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
+MOSQUITTO_DEPENDENCIES += libopenssl
 MOSQUITTO_MAKE_OPTS += WITH_TLS=yes
 else
 MOSQUITTO_MAKE_OPTS += WITH_TLS=no