package/efl/libefl: add jp2k config option
authorRomain Naour <romain.naour@openwide.fr>
Tue, 15 Dec 2015 22:40:18 +0000 (23:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 17 Dec 2015 22:54:04 +0000 (23:54 +0100)
Like for webp format, add an option to enable the JPEG 2000
codec support in the efl libraries.

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/libefl/Config.in
package/efl/libefl/libefl.mk

index 2a5149ed1ddffe5d36169a39329ecfee97fd27dd..3ce5606140eca5d3c7548f087e8323beb57cb643 100644 (file)
@@ -123,6 +123,13 @@ config BR2_PACKAGE_LIBEFL_PNG
          This enables the loader code that loads png files using
          libpng.
 
+config BR2_PACKAGE_LIBEFL_JP2K
+       bool "libevas jp2k loader"
+       select BR2_PACKAGE_OPENJPEG
+       help
+         This enables the loader code that loads jp2k files using
+         openjpeg.
+
 config BR2_PACKAGE_LIBEFL_JPEG
        bool "libevas jpeg loader"
        help
index 75af6c9a2045cd2b7b398521479c43dc8673694b..5c0244062e16706a54bd52ec7f6858f397de3589 100644 (file)
@@ -30,7 +30,6 @@ LIBEFL_GETTEXTIZE = YES
 
 # Configure options:
 # --disable-cxx-bindings: disable C++11 bindings.
-# --disable-image-loader-jp2k: disable JPEG 2000 support.
 # --disable-sdl: disable sdl2 support.
 # --disable-systemd: disable systemd support.
 # --enable-lua-old: disable Elua and remove luajit dependency.
@@ -40,7 +39,6 @@ LIBEFL_CONF_OPTS = \
        --with-edje-cc=$(HOST_DIR)/usr/bin/edje_cc \
        --with-eolian-gen=$(HOST_DIR)/usr/bin/eolian_gen \
        --disable-cxx-bindings \
-       --disable-image-loader-jp2k \
        --disable-sdl \
        --disable-systemd \
        --enable-lua-old \
@@ -178,6 +176,13 @@ else
 LIBEFL_CONF_OPTS += --disable-image-loader-tiff
 endif
 
+ifeq ($(BR2_PACKAGE_LIBEFL_JP2K),y)
+LIBEFL_CONF_OPTS += --enable-image-loader-jp2k=yes
+LIBEFL_DEPENDENCIES += openjpeg
+else
+LIBEFL_CONF_OPTS += --disable-image-loader-jp2k
+endif
+
 ifeq ($(BR2_PACKAGE_LIBEFL_WEBP),y)
 LIBEFL_CONF_OPTS += --enable-image-loader-webp=yes
 LIBEFL_DEPENDENCIES += webp