tinycbor: disable parallel build
authorPeter Seiderer <ps.report@gmx.net>
Fri, 16 Dec 2016 22:30:22 +0000 (23:30 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Dec 2016 13:19:56 +0000 (14:19 +0100)
Maybe fixes ([1]):

 make[1]: Entering directory `/home/peko/autobuild/instance-1/output/build/tinycbor-v0.4'
 .config:8: *** missing separator.  Stop.

[1] http://autobuild.buildroot.net/results/8e8fd1e19d6d07212f29e19a305712e715fe781b

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tinycbor/tinycbor.mk

index 2691e5b8d3cbc4ee516df9dcbc25426ee3fc8165..65deacd22b8382689b43b1742020b9aac30d0d6b 100644 (file)
@@ -18,8 +18,10 @@ endif
 
 TINYCBOR_MAKE_OPTS = $(TARGET_CONFIGURE_OPTS) V=1
 
+# disabled parallel build because of build failures while
+# producing the .config file
 define TINYCBOR_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) $(TINYCBOR_MAKE_OPTS) -C $(@D)
+       $(TARGET_MAKE_ENV) $(MAKE1) $(TINYCBOR_MAKE_OPTS) -C $(@D)
 endef
 
 define TINYCBOR_INSTALL_STAGING_CMDS