package/vdr-plugin-vnsiserver: fix build with pkgconf 1.5.3
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 14 Dec 2018 21:25:51 +0000 (22:25 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 14 Dec 2018 21:39:35 +0000 (22:39 +0100)
Since the bump to 1.5.3, pkgconf prepends the sysroot to all absolute
paths found in the .pc file. This is correct when the paths refer to
something in STAGING_DIR (e.g. libdir, includedir), but not when it
refers to something used for the target.

vdr-plugin-vnsiserver uses the locdir variable from vdr.pc to decide
where to install things. Since DESTDIR is prepended to the install
destination, this will end up in the wrong location.

Until a better solution is found in pkgconf, pass the LOCDIR to use
explicitly instead of relying on vdr.pc.

Fixes:
 - http://autobuild.buildroot.org/results/9be3719f7b2137a5f039f3c4209c3bc7edeae2b4

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vdr-plugin-vnsiserver/vdr-plugin-vnsiserver.mk

index a25a99dfa8832da5c7638950a29db5fe40b9004f..f41ad701d3fd97d94814e9d5998121879db62b90 100644 (file)
@@ -19,7 +19,8 @@ endef
 
 define VDR_PLUGIN_VNSISERVER_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
-               install DESTDIR=$(TARGET_DIR) LIBDIR=/usr/lib/vdr
+               install DESTDIR=$(TARGET_DIR) LIBDIR=/usr/lib/vdr \
+               LOCDIR=/usr/share/locale
 endef
 
 $(eval $(generic-package))