sdl_sound: add optional dependencies
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 4 Jul 2010 06:56:00 +0000 (08:56 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 4 Jul 2010 06:57:09 +0000 (08:57 +0200)
Add the optional dependencies we have in BR (flac/speex/vorbis).

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/sdl_sound/sdl_sound.mk

index 5058551b017dcf6925228825ef88fc3bfc949ea2..3a6b7e74201e0c3c0e17a63c47f402ca39feb25c 100644 (file)
@@ -15,6 +15,19 @@ ifneq ($(BR2_ENABLE_LOCALE),y)
 SDL_SOUND_DEPENDENCIES += libiconv
 endif
 
+# optional dependencies
+ifeq ($(BR2_PACKAGE_FLAC),y)
+SDL_SOUND_DEPENDENCIES += flac # is only used if ogg is also enabled
+endif
+
+ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
+SDL_SOUND_DEPENDENCIES += libvorbis
+endif
+
+ifeq ($(BR2_PACKAGE_SPEEX),y)
+SDL_SOUND_DEPENDENCIES += speex
+endif
+
 SDL_SOUND_CONF_OPT:=--with-sdl-prefix=$(STAGING_DIR)/usr \
                --with-sdl-exec-prefix=$(STAGING_DIR)/usr \
                --disable-sdltest \