package/waylandpp: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 22 Nov 2017 18:34:20 +0000 (19:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 23 Nov 2017 21:13:17 +0000 (22:13 +0100)
Building waylandpp for the target requires a wayland-scanner++ binary
built for the host.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Thomas: use 'depends on BR2_PACKAGE_WAYLAND' instead of a select.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/waylandpp/Config.in [new file with mode: 0644]
package/waylandpp/waylandpp.hash [new file with mode: 0644]
package/waylandpp/waylandpp.mk [new file with mode: 0644]

index f93c617cf57c1a9ca8f35f361ede582b32e673a2..fe943d3d85ff96106641df305c93dfc8fa704466 100644 (file)
@@ -337,6 +337,7 @@ F:  package/vdr/
 F:     package/vdr-plugin-vnsiserver/
 F:     package/vlc/
 F:     package/vnstat/
+F:     package/waylandpp/
 F:     package/x11r7/
 F:     package/x264/
 F:     package/x265/
index 54f6f57e6d667a41bacf96084176ce5e44d1197e..0f5b7df3222aac6b46149de7653cc745dcbf7dc9 100644 (file)
@@ -1145,6 +1145,7 @@ menu "Graphics"
        source "package/tiff/Config.in"
        source "package/wayland/Config.in"
        source "package/wayland-protocols/Config.in"
+       source "package/waylandpp/Config.in"
        source "package/webkitgtk/Config.in"
        source "package/webp/Config.in"
        source "package/zbar/Config.in"
diff --git a/package/waylandpp/Config.in b/package/waylandpp/Config.in
new file mode 100644 (file)
index 0000000..3d7362b
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_WAYLANDPP
+       bool "waylandpp"
+       depends on BR2_PACKAGE_HAS_LIBEGL_WAYLAND
+       depends on BR2_HOST_GCC_AT_LEAST_4_9
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
+       depends on BR2_PACKAGE_WAYLAND
+       help
+         Wayland C++ bindings
+
+         https://github.com/NilsBrause/waylandpp
+
+comment "waylandpp needs an OpenGL-EGL/wayland backend, a toolchain w/ gcc >= 4.9, host gcc >= 4.9"
+       depends on BR2_PACKAGE_WAYLAND
+       depends on !BR2_PACKAGE_HAS_LIBEGL_WAYLAND || \
+               !BR2_HOST_GCC_AT_LEAST_4_9 || \
+               !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
diff --git a/package/waylandpp/waylandpp.hash b/package/waylandpp/waylandpp.hash
new file mode 100644 (file)
index 0000000..7e793cc
--- /dev/null
@@ -0,0 +1,4 @@
+# Locally computed
+sha256 3d6d07a6fa4164c092608cdc53172af11138fbe7b7a9894090ca6502d8153448  waylandpp-0.1.5.tar.gz
+sha256 49aa6d728fd13226952c9e3a5a9cae46379b2a501010064760172b5ce7cd94bb  LICENSE
+sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  scanner/gpl-3.0.txt
diff --git a/package/waylandpp/waylandpp.mk b/package/waylandpp/waylandpp.mk
new file mode 100644 (file)
index 0000000..0054838
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# waylandpp
+#
+################################################################################
+
+WAYLANDPP_VERSION = 0.1.5
+WAYLANDPP_SITE = $(call github,NilsBrause,waylandpp,$(WAYLANDPP_VERSION))
+WAYLANDPP_LICENSE = MIT, GPL-3.0+ (wayland_scanner)
+WAYLANDPP_LICENSE_FILES = LICENSE scanner/gpl-3.0.txt
+WAYLANDPP_INSTALL_STAGING = YES
+HOST_WAYLANDPP_DEPENDENCIES = host-pkgconf host-wayland
+WAYLANDPP_DEPENDENCIES = libegl host-pkgconf wayland host-waylandpp
+
+# host variant of wayland-scanner++ is needed for building the target
+# package
+HOST_WAYLANDPP_CONF_OPTS = \
+       -DBUILD_LIBRARIES=OFF \
+       -DBUILD_SCANNER=ON
+
+WAYLANDPP_CONF_OPTS = \
+       -DBUILD_LIBRARIES=ON \
+       -DBUILD_SCANNER=OFF \
+       -DWAYLAND_SCANNERPP=$(HOST_DIR)/bin/wayland-scanner++
+
+$(eval $(cmake-package))
+$(eval $(host-cmake-package))