package/systemd: use interface name for networkd config file
authorPascal de Bruijn <p.debruijn@unilogic.nl>
Wed, 8 Jan 2020 10:44:39 +0000 (11:44 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 3 Feb 2020 22:43:49 +0000 (23:43 +0100)
By using the interface in the filename for the networkd config file,
we have a clear association between the config file and the interface
it applies to.

This is beneficical for systems that have multiple interfaces.

Signed-off-by: Pascal de Bruijn <p.debruijn@unilogic.nl>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd/systemd.mk

index 791e770ca1da6d2d0d23809e518b16ca08ee34a2..6e31a14ac35fdd3e88b9c887ab784e02c4db4c35 100644 (file)
@@ -330,7 +330,7 @@ ifneq ($(SYSTEMD_NETWORKD_DHCP_IFACE),)
 define SYSTEMD_INSTALL_NETWORK_CONFS
        sed s/SYSTEMD_NETWORKD_DHCP_IFACE/$(SYSTEMD_NETWORKD_DHCP_IFACE)/ \
                $(SYSTEMD_PKGDIR)/dhcp.network > \
-               $(TARGET_DIR)/etc/systemd/network/dhcp.network
+               $(TARGET_DIR)/etc/systemd/network/$(SYSTEMD_NETWORKD_DHCP_IFACE).network
 endef
 endif
 else