gst1-plugins-bad: cleanup of build options
authorMarcin Nowakowski <marcin.nowakowski@imgtec.com>
Fri, 24 Jun 2016 06:12:21 +0000 (08:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 25 Jun 2016 13:26:07 +0000 (15:26 +0200)
Remove non-existing options:
 * --disable-wsap
 * --disable-direct3d
 * --disable-gsettings

Remove options that are already handled later in the .mk file, using
optional dependencies:
 * --disable-rtmp
 * --disable-hls
 * --disable-dash

Rename disable->strp to disable-srtp, which essentially fixes a typo.

Remove liveadder plugin - no longer a separate built option, it's been
merged into audiomixer. Config.in.legacy handling is added for the
removed option.

Signed-off-by: Marcin Nowakowski <marcin.nowakowski@imgtec.com>
[Thomas: add Config.in.legacy handling for the liveaddr plugin option,
tweaks to the commit log.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index bb12d7b57fe06c4d08d014d0efe370640188543c..34bdaf0f8124c88ec6e33aa61e32b7a4d4075286 100644 (file)
@@ -145,6 +145,14 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.08"
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_LIVEADDER
+       bool "gst1-plugins-bad liveadder plugin removed"
+       select BR2_LEGACY
+       select BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_AUDIOMIXER
+       help
+         The functionality of the liveadder plugin of the
+         gst1-plugins-bad package has been merged into audiomixer.
+
 config BR2_PACKAGE_LIBFSLVPUWRAP
        bool "libfslvpuwrap has been renamed to imx-vpuwrap"
        select BR2_LEGACY
index 046c2aabd216b7443df37451c779dbd65253024b..0f9fb154dc485528bc9be4dac3c0f59c52c61e09 100644 (file)
@@ -312,11 +312,6 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_LIBRFB
        help
          Connects to a VNC server and decodes RFB stream
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_LIVEADDER
-       bool "liveadder"
-       help
-         Adds multiple live discontinuous streams
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MIDI
        bool "midi"
        help
index 271569ed2dd607719027ffa2165513296b3f92ac..8f739ecbdca5ba7e4ae7fb061930fe1a3dcf51ee 100644 (file)
@@ -17,9 +17,7 @@ GST1_PLUGINS_BAD_CONF_OPTS = \
        --disable-examples \
        --disable-valgrind \
        --disable-directsound \
-       --disable-wsapi \
        --disable-direct3d \
-       --disable-direct3d9 \
        --disable-winks \
        --disable-android_media \
        --disable-apple_media \
@@ -35,7 +33,6 @@ GST1_PLUGINS_BAD_CONF_OPTS += \
        --disable-voamrwbenc \
        --disable-bs2b \
        --disable-chromaprint \
-       --disable-dash \
        --disable-dc1394 \
        --disable-dts \
        --disable-resindvd \
@@ -47,7 +44,7 @@ GST1_PLUGINS_BAD_CONF_OPTS += \
        --disable-ladspa \
        --disable-lv2 \
        --disable-libde265 \
-       --disable-strp \
+       --disable-srtp \
        --disable-linsys \
        --disable-modplug \
        --disable-mimic \
@@ -69,11 +66,8 @@ GST1_PLUGINS_BAD_CONF_OPTS += \
        --disable-vdpau \
        --disable-schro \
        --disable-zbar \
-       --disable-rtmp \
        --disable-spandsp \
-       --disable-gsettings \
        --disable-sndio \
-       --disable-hls \
        --disable-gtk3 \
        --disable-qt
 
@@ -376,12 +370,6 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-librfb
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_LIVEADDER),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-liveadder
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-liveadder
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MIDI),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-midi
 else