package/harfbuzz: bump to version 2.7.4
authorFrancois Perrad <fperrad@gmail.com>
Mon, 4 Jan 2021 21:02:11 +0000 (22:02 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 4 Jan 2021 22:09:31 +0000 (23:09 +0100)
remove merged patch

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/harfbuzz/0001-meson.build-check-for-pthread.h.patch [new file with mode: 0644]
package/harfbuzz/0001-src-meson.build-allow-introspection-when-cross-compi.patch [deleted file]
package/harfbuzz/0002-meson.build-check-for-pthread.h.patch [deleted file]
package/harfbuzz/harfbuzz.hash
package/harfbuzz/harfbuzz.mk

diff --git a/package/harfbuzz/0001-meson.build-check-for-pthread.h.patch b/package/harfbuzz/0001-meson.build-check-for-pthread.h.patch
new file mode 100644 (file)
index 0000000..6d7225c
--- /dev/null
@@ -0,0 +1,49 @@
+From 96bbf3a3af45d86f790afdf91a6686c37421e92b Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Sun, 15 Nov 2020 10:57:37 +0100
+Subject: [PATCH] meson.build: check for pthread.h
+
+Check for pthread.h otherwise the build will fail with some toolchains
+that have libphtread.so but not pthread.h:
+
+Run-time dependency threads found: YES
+
+../src/hb-mutex.hh:53:10: fatal error: pthread.h: No such file or directory
+ #include <pthread.h>
+          ^~~~~~~~~~~
+
+Moreover, fix detection of pthread fallback
+
+Fixes:
+ - http://autobuild.buildroot.org/results/70c98e89b1d5e5b651d1f6928dc53f465103f57a
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ meson.build | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index bf3925db..6d263d48 100644
+--- a/meson.build
++++ b/meson.build
+@@ -281,13 +281,15 @@ endif
+ # threads
+ thread_dep = null_dep
+ if host_machine.system() != 'windows'
+-  thread_dep = dependency('threads', required: false)
++  if cpp.has_header('pthread.h')
++    thread_dep = dependency('threads', required: false)
++  endif
+   if thread_dep.found()
+     conf.set('HAVE_PTHREAD', 1)
+   else
+     check_headers += ['sched.h']
+-    check_funcs += ['sched_yield', {'link_with': 'rt'}]
++    check_funcs += [['sched_yield', {'link_with': 'rt'}]]
+   endif
+ endif
+-- 
+2.29.2
+
diff --git a/package/harfbuzz/0001-src-meson.build-allow-introspection-when-cross-compi.patch b/package/harfbuzz/0001-src-meson.build-allow-introspection-when-cross-compi.patch
deleted file mode 100644 (file)
index 700f6f8..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From 432dfd0a1d8fe0a8df89e7ce828c520c7758f10c Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Thu, 24 Sep 2020 21:00:34 +0200
-Subject: [PATCH] src/meson.build: allow introspection when cross-compiling
-
-introspection can be enabled when cross-compiling on certains conditions
-(for example it is supported by buildroot)
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Upstream status: https://github.com/harfbuzz/harfbuzz/pull/2692]
----
- src/meson.build | 5 -----
- 1 file changed, 5 deletions(-)
-
-diff --git a/src/meson.build b/src/meson.build
-index 19290245..7db43508 100644
---- a/src/meson.build
-+++ b/src/meson.build
-@@ -637,11 +637,6 @@ if have_gobject
-   gir = find_program('g-ir-scanner', required: get_option('introspection'))
-   build_gir = gir.found()
--  build_gir = build_gir and not meson.is_cross_build()
--  if not build_gir and get_option('introspection').enabled()
--    error('Introspection support is requested but it isn\'t available in cross builds')
--  endif
--
-   build_gir = build_gir and get_option('default_library') != 'static'
-   if not build_gir and get_option('introspection').enabled()
-     error('Introspection support is requested but the default library option should be shared or both')
--- 
-2.28.0
-
diff --git a/package/harfbuzz/0002-meson.build-check-for-pthread.h.patch b/package/harfbuzz/0002-meson.build-check-for-pthread.h.patch
deleted file mode 100644 (file)
index 128876d..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-From 96bbf3a3af45d86f790afdf91a6686c37421e92b Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Sun, 15 Nov 2020 10:57:37 +0100
-Subject: [PATCH] meson.build: check for pthread.h
-
-Check for pthread.h otherwise the build will fail with some toolchains
-that have libphtread.so but not pthread.h:
-
-Run-time dependency threads found: YES
-
-../src/hb-mutex.hh:53:10: fatal error: pthread.h: No such file or directory
- #include <pthread.h>
-          ^~~~~~~~~~~
-
-Moreover, fix detection of pthread fallback
-
-Fixes:
- - http://autobuild.buildroot.org/results/70c98e89b1d5e5b651d1f6928dc53f465103f57a
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- meson.build | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index bf3925db..6d263d48 100644
---- a/meson.build
-+++ b/meson.build
-@@ -284,13 +284,15 @@ endif
- # threads
- thread_dep = null_dep
- if host_machine.system() != 'windows'
--  thread_dep = dependency('threads', required: false)
-+  if cpp.has_header('pthread.h')
-+    thread_dep = dependency('threads', required: false)
-+  endif
-   if thread_dep.found()
-     conf.set('HAVE_PTHREAD', 1)
-   else
-     check_headers += ['sched.h']
--    check_funcs += ['sched_yield', {'link_with': 'rt'}]
-+    check_funcs += [['sched_yield', {'link_with': 'rt'}]]
-   endif
- endif
--- 
-2.29.2
-
index dac859bbd4a2e996525ce5bb71865d49c7c4d4ad..98b137c8bd208c7174e13dd6cdc53c44ce0bde70 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed
-sha256  b8c048d7c2964a12f2c80deb6634dfc836b603dd12bf0d0a3df1627698e220ce  harfbuzz-2.7.2.tar.xz
+sha256  6ad11d653347bd25d8317589df4e431a2de372c0cf9be3543368e07ec23bb8e7  harfbuzz-2.7.4.tar.xz
 sha256  beb3f017ceb41387667f78237a7cecf84defa0ed257c505894663d6a9f13211b  COPYING
index fae9278b7c4333feb39e693828fa7e8a14b8d3fa..a17283bea92942028d1716a37e9bd6cb7498c5a7 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-HARFBUZZ_VERSION = 2.7.2
+HARFBUZZ_VERSION = 2.7.4
 HARFBUZZ_SITE = https://github.com/harfbuzz/harfbuzz/releases/download/$(HARFBUZZ_VERSION)
 HARFBUZZ_SOURCE = harfbuzz-$(HARFBUZZ_VERSION).tar.xz
 HARFBUZZ_LICENSE = MIT, ISC (ucdn library)