package/asterisk: add optional support for openssl
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 9 Sep 2017 21:39:11 +0000 (23:39 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 23 Sep 2017 17:20:18 +0000 (19:20 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/asterisk/asterisk.mk

index a3a37033805b721211f980aa602856c2e12ecb79..8d21601e3e6579a653019ba0ddf5fc6c9cfcb93b 100644 (file)
@@ -102,7 +102,6 @@ ASTERISK_CONF_OPTS = \
        --without-speexdsp \
        --without-sqlite \
        --without-srtp \
-       --without-ssl \
        --without-suppserv \
        --without-tds \
        --without-termcap \
@@ -145,6 +144,13 @@ else
 ASTERISK_CONF_OPTS += --without-gsm
 endif
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+ASTERISK_DEPENDENCIES += openssl
+ASTERISK_CONF_OPTS += --with-ssl
+else
+ASTERISK_CONF_OPTS += --without-ssl
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 ASTERISK_DEPENDENCIES += zlib
 ASTERISK_CONF_OPTS += --with-z