package/openrc: bump to version 0.42.1
authorAdam Duskett <Aduskett@gmail.com>
Sun, 1 Mar 2020 15:17:45 +0000 (12:17 -0300)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 11 Mar 2020 17:20:07 +0000 (18:20 +0100)
Add a patch to prevent starting agetty on tty[1-6]. Buildroot starts a
single getty, according to the system configuration. Also tty[1-6] may
not even exist (e.g. embedded devices with serial consoles only).

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Carlos Santos <unixmania@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/openrc/0005-runlevels-do-not-add-agetty.tty-1-6-if-MKSYSVINIT-ye.patch [new file with mode: 0644]
package/openrc/openrc.hash
package/openrc/openrc.mk

diff --git a/package/openrc/0005-runlevels-do-not-add-agetty.tty-1-6-if-MKSYSVINIT-ye.patch b/package/openrc/0005-runlevels-do-not-add-agetty.tty-1-6-if-MKSYSVINIT-ye.patch
new file mode 100644 (file)
index 0000000..733506a
--- /dev/null
@@ -0,0 +1,34 @@
+From 014dc43447fa553e875984ac4a528e5916cc9e06 Mon Sep 17 00:00:00 2001
+From: Carlos Santos <unixmania@gmail.com>
+Date: Sat, 29 Feb 2020 22:41:30 -0300
+Subject: [PATCH] runlevels: do not add agetty.tty[1-6] if MKSYSVINIT=yes
+
+Buildroot starts a single getty, according to the system configuration.
+Also tty[1-6] may not exist (e.g. embedded devices with serial consoles
+only).
+
+Signed-off-by: Carlos Santos <unixmania@gmail.com>
+---
+ runlevels/Makefile | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/runlevels/Makefile b/runlevels/Makefile
+index 73843d8b..dbfb59ca 100644
+--- a/runlevels/Makefile
++++ b/runlevels/Makefile
+@@ -90,12 +90,6 @@ install:
+                       fi; \
+                       ln -snf ${INITDIR}/"$$x" ${SHUTDOWNDIR}/"$$x" || exit $$?; done \
+       fi
+-      if test "${MKSYSVINIT}" = yes && test "${OS}" = Linux; then \
+-              for x in tty1 tty2 tty3 tty4 tty5 tty6; do \
+-                      ln -snf ${INITDIR}/agetty ${DESTDIR}/${INITDIR}/"agetty.$$x" || exit $$?; \
+-                      ln -snf ${INITDIR}/agetty.$$x ${DEFAULTDIR}/"agetty.$$x" || exit $$?; \
+-              done; \
+-      fi
+ check test::
+-- 
+2.18.2
+
index 7d58e254c487935c507b8bf56a619fb1754616b3..bb5880806d9f68f05418944451d3f2ba254f420c 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 c99488ca54f2b795328d07bbd456ade49b571136bba7501f7eaaeb1ca9f9ecc4        openrc-0.41.2.tar.gz
+sha256 91a01ca6d930a0688fb91338209985de57cac7aa2d37feddacb78fd3d95308e2        openrc-0.42.1.tar.gz
 sha256 96862463f4e77e2508e4fc2c83773fd24807cb699368b63fd93a5e2b466dd624        LICENSE
index ce0b05e96583b3efed7635bf8544905f0e68c34f..6057451bfe3c2106d0f6007ac0d262220f9d76b7 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-OPENRC_VERSION = 0.41.2
+OPENRC_VERSION = 0.42.1
 OPENRC_SITE = $(call github,OpenRC,openrc,$(OPENRC_VERSION))
 OPENRC_LICENSE = BSD-2-Clause
 OPENRC_LICENSE_FILES = LICENSE