pthread-stubs: rename to xlib_libpthread-stubs
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 2 Jan 2013 01:26:38 +0000 (01:26 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 5 Jan 2013 12:26:14 +0000 (13:26 +0100)
In upstream X.org releases, pthread-stubs is named libpthread-stubs,
so for consistency reasons, we rename the Buildroot package
accordingly. Also, while we're at it, we add a xlib_ prefix to the
package to match other X.org libraries in Buildroot.

The necessary Config.in.legacy code is added to ensure that users
having .config files using the old configuration option name get a
warning.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Config.in.legacy
package/libdrm/libdrm.mk
package/x11r7/Config.in
package/x11r7/libxcb/libxcb.mk
package/x11r7/pthread-stubs/Config.in [deleted file]
package/x11r7/pthread-stubs/pthread-stubs.mk [deleted file]
package/x11r7/xlib_libpthread-stubs/Config.in [new file with mode: 0644]
package/x11r7/xlib_libpthread-stubs/xlib_libpthread-stubs.mk [new file with mode: 0644]

index 7ddc6eaa2bcc91b6687e76756bb8d2b3ebcb9c9b..4770c947969bb1f4310294ec463cc72f39ccad63 100644 (file)
@@ -70,4 +70,12 @@ config BR2_PACKAGE_INPUT_TOOLS_EVTEST
        help
          The evtest program from input-tools is now a separate package.
 
+config BR2_PACKAGE_PTHREAD_STUBS
+       bool "pthread-stubs option has been renamed"
+       select BR2_LEGACY
+       select BR2_PACKAGE_XLIB_LIBPTHREAD_STUBS
+       help
+         For consistency reason, the pthread-stubs package has been
+         renamed to xlib_libpthread-stubs.
+
 endif
index fbfc95ece3970f58c921cd2c71d444b1baf71308..4ccfa522f69d983e55ee19f84ebc84144846b11a 100644 (file)
@@ -14,7 +14,7 @@ LIBDRM_DEPENDENCIES = \
        xlib_libXxf86vm \
        xlib_libXmu \
        xproto_dri2proto \
-       pthread-stubs \
+       xlib_libpthread-stubs \
        host-pkgconf
 
 ifeq ($(BR2_PACKAGE_XDRIVER_XF86_VIDEO_INTEL),y)
index 6881d4ed95965ecc4be299f0a065709aab4c631e..9e08e3f279e854d723acec7a416f9d86941509e9 100644 (file)
@@ -37,7 +37,6 @@ endmenu
        menu "X11R7 Libraries"
                source package/x11r7/libxcb/Config.in
                source package/x11r7/mesa3d/Config.in
-               source package/x11r7/pthread-stubs/Config.in
                source package/x11r7/xcb-util/Config.in
                source package/x11r7/xcb-util-keysyms/Config.in
                source package/x11r7/xlib_libFS/Config.in
@@ -79,6 +78,7 @@ endmenu
                source package/x11r7/xlib_libxkbui/Config.in
                source package/x11r7/xlib_xtrans/Config.in
                source package/x11r7/xlib_libpciaccess/Config.in
+               source package/x11r7/xlib_libpthread-stubs/Config.in
        endmenu
        menu "X11R7 Applications"
                source package/x11r7/xapp_appres/Config.in
index f7b194591a049ef7c23b360eb019ab80831e3635..15eeeef44f2804bda14011fc2ea9a1c10889f911 100644 (file)
@@ -10,7 +10,7 @@ LIBXCB_SITE = http://xcb.freedesktop.org/dist/
 LIBXCB_INSTALL_STAGING = YES
 
 LIBXCB_DEPENDENCIES = \
-       host-libxslt pthread-stubs xcb-proto xlib_libXdmcp xlib_libXau \
+       host-libxslt xlib_libpthread-stubs xcb-proto xlib_libXdmcp xlib_libXau \
        host-xcb-proto host-python host-pkgconf
 LIBXCB_CONF_ENV = STAGING_DIR="$(STAGING_DIR)"
 LIBXCB_MAKE_OPT = XCBPROTO_XCBINCLUDEDIR=$(STAGING_DIR)/usr/share/xcb \
diff --git a/package/x11r7/pthread-stubs/Config.in b/package/x11r7/pthread-stubs/Config.in
deleted file mode 100644 (file)
index c17f7da..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-config BR2_PACKAGE_PTHREAD_STUBS
-       bool "pthread-stubs"
-       help
-         This library provides weak aliases for pthread functions not
-         provided in libc or otherwise available by default.
-
-         http://xcb.freedesktop.org/
diff --git a/package/x11r7/pthread-stubs/pthread-stubs.mk b/package/x11r7/pthread-stubs/pthread-stubs.mk
deleted file mode 100644 (file)
index e7032de..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-#############################################################
-#
-# pthread-stubs
-#
-#############################################################
-PTHREAD_STUBS_VERSION = 0.3
-PTHREAD_STUBS_SOURCE = libpthread-stubs-$(PTHREAD_STUBS_VERSION).tar.bz2
-PTHREAD_STUBS_SITE = http://xcb.freedesktop.org/dist/
-
-PTHREAD_STUBS_INSTALL_STAGING = YES
-
-$(eval $(autotools-package))
-$(eval $(host-autotools-package))
-
diff --git a/package/x11r7/xlib_libpthread-stubs/Config.in b/package/x11r7/xlib_libpthread-stubs/Config.in
new file mode 100644 (file)
index 0000000..fb53585
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_XLIB_LIBPTHREAD_STUBS
+       bool "libpthread-stubs"
+       help
+         This library provides weak aliases for pthread functions not
+         provided in libc or otherwise available by default.
+
+         http://xcb.freedesktop.org/
diff --git a/package/x11r7/xlib_libpthread-stubs/xlib_libpthread-stubs.mk b/package/x11r7/xlib_libpthread-stubs/xlib_libpthread-stubs.mk
new file mode 100644 (file)
index 0000000..909253c
--- /dev/null
@@ -0,0 +1,14 @@
+#############################################################
+#
+# xlib_libpthread-stubs
+#
+#############################################################
+XLIB_LIBPTHREAD_STUBS_VERSION = 0.3
+XLIB_LIBPTHREAD_STUBS_SOURCE = libpthread-stubs-$(XLIB_LIBPTHREAD_STUBS_VERSION).tar.bz2
+XLIB_LIBPTHREAD_STUBS_SITE = http://xcb.freedesktop.org/dist/
+
+XLIB_LIBPTHREAD_STUBS_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))
+