xbmc: add host-yasm dependency for MMX/64bit archs
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 7 Jun 2014 12:31:04 +0000 (14:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 8 Jun 2014 12:59:27 +0000 (14:59 +0200)
Fixes error during xbmc configure:

yasm not found, use --disable-yasm for a crippled build

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solving the problem.
configure: error: Submodule lib/ffmpeg failed to configure

This will be needed for 13.0 Gotham.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xbmc/xbmc.mk

index 35228026fcfeb40bc381ce726db58268b8d6508a..ffe573f29f4628b3e616d6586e5ad62be2411020 100644 (file)
@@ -21,6 +21,13 @@ XBMC_DEPENDENCIES += boost bzip2 expat flac fontconfig freetype jasper jpeg \
 # xbmc@i386 depends on nasm
 XBMC_DEPENDENCIES += $(if $(BR2_i386),host-nasm)
 
+# ffmpeg depends on yasm on MMX archs
+# xbmc configure passes $(BR2_ARCH) to ffmpeg configure which adds
+# yasm as dependency for x86_64, even if BR2_x86_generic=y
+ifneq ($(BR2_X86_CPU_HAS_MMX)$(BR2_x86_64),)
+XBMC_DEPENDENCIES += host-yasm
+endif
+
 XBMC_CONF_ENV = \
        PYTHON_VERSION="$(PYTHON_VERSION_MAJOR)" \
        PYTHON_LDFLAGS="-lpython$(PYTHON_VERSION_MAJOR) -lpthread -ldl -lutil -lm" \