dmraid: rename init script and use FOO_INSTALL_INIT_SYSV
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Tue, 4 Feb 2014 10:06:05 +0000 (11:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 2 Mar 2014 15:30:48 +0000 (16:30 +0100)
This commit fixes the init script to use the correct
FOO_INSTALL_INIT_SYSV hook.

[Thomas: slightly reword commit log.]

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dmraid/S20dmraid [new file with mode: 0644]
package/dmraid/dmraid.init [deleted file]
package/dmraid/dmraid.mk

diff --git a/package/dmraid/S20dmraid b/package/dmraid/S20dmraid
new file mode 100644 (file)
index 0000000..fd2ad9e
--- /dev/null
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+set -e
+
+[ -x /usr/sbin/dmraid ] || exit 0
+
+# try to load module in case that hasn't been done yet
+modprobe dm-mod >/dev/null 2>&1
+
+case "$1" in
+       start|"")
+               echo "Setting up DMRAID devices..."
+               /usr/sbin/dmraid --activate yes --ignorelocking --verbose
+               ;;
+
+       stop)
+               echo "Shutting down DMRAID devices... "
+               /usr/sbin/dmraid --activate no --ignorelocking --verbose
+               ;;
+
+       restart|force-reload)
+               $0 stop
+               sleep 1
+               $0 start
+               ;;
+
+       *)
+               echo "Usage: dmraid {start|stop|restart|force-reload}"
+               exit 1
+               ;;
+esac
diff --git a/package/dmraid/dmraid.init b/package/dmraid/dmraid.init
deleted file mode 100644 (file)
index fd2ad9e..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-#!/bin/sh
-
-set -e
-
-[ -x /usr/sbin/dmraid ] || exit 0
-
-# try to load module in case that hasn't been done yet
-modprobe dm-mod >/dev/null 2>&1
-
-case "$1" in
-       start|"")
-               echo "Setting up DMRAID devices..."
-               /usr/sbin/dmraid --activate yes --ignorelocking --verbose
-               ;;
-
-       stop)
-               echo "Shutting down DMRAID devices... "
-               /usr/sbin/dmraid --activate no --ignorelocking --verbose
-               ;;
-
-       restart|force-reload)
-               $0 stop
-               sleep 1
-               $0 start
-               ;;
-
-       *)
-               echo "Usage: dmraid {start|stop|restart|force-reload}"
-               exit 1
-               ;;
-esac
index 089e33a2f8e952d5f3b58a61152795c77114544a..412c90365b760fd17536a51d138bb66900268a71 100644 (file)
@@ -15,10 +15,10 @@ DMRAID_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
 
 DMRAID_DEPENDENCIES = lvm2
 
-define DMRAID_INSTALL_INITSCRIPT
-       $(INSTALL) -m 0755 package/dmraid/dmraid.init $(TARGET_DIR)/etc/init.d/S20dmraid
+define DMRAID_INSTALL_INIT_SYSV
+    [ -f $(TARGET_DIR)/etc/init.d/S20dmraid ] || \
+        $(INSTALL) -D -m 0755 package/dmraid/S20dmraid \
+            $(TARGET_DIR)/etc/init.d/S20dmraid
 endef
 
-DMRAID_POST_INSTALL_TARGET_HOOKS += DMRAID_INSTALL_INITSCRIPT
-
 $(eval $(autotools-package))