package/tvheadend: use a non-root user to run the daemon
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 12 Apr 2013 07:14:19 +0000 (07:14 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 25 Apr 2013 20:57:00 +0000 (22:57 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/tvheadend/etc.default.tvheadend
package/tvheadend/tvheadend.mk

index c76905583530e67eab03f65cabce1e622a2ddc92..253f8320b1f81f0719da55aa4aa77039ac7e6ca7 100644 (file)
@@ -1,6 +1,5 @@
-# Once we have a real user, we'll use it
-TVH_USER=root
-TVH_GROUP=root
+TVH_USER=tvheadend
+TVH_GROUP=tvheadend
 #TVH_ADAPTERS=
 #TVH_HTTP_PORT=9981
 #TVH_HTSP_PORT=9982
index 5a971b854d9bc2a6af2534e41d14a46f328e56b6..58965d6831725cd1b2055ca6513c493f018113f5 100644 (file)
@@ -26,9 +26,11 @@ TVHEADEND_DEPENDENCIES     += dvb-apps
 # To run tvheadend, we need:
 #  - a startup script, and its config file
 #  - a default DB with a tvheadend admin
+#  - a non-root user to run as
 define TVHEADEND_INSTALL_DB
-       $(INSTALL) -D package/tvheadend/accesscontrol.1     \
-                     $(TARGET_DIR)/root/.hts/tvheadend/accesscontrol/1
+       $(INSTALL) -D -m 0600 package/tvheadend/accesscontrol.1     \
+                     $(TARGET_DIR)/home/tvheadend/.hts/tvheadend/accesscontrol/1
+       chmod -R go-rwx $(TARGET_DIR)/home/tvheadend
 endef
 TVHEADEND_POST_INSTALL_TARGET_HOOKS  = TVHEADEND_INSTALL_DB
 
@@ -37,6 +39,10 @@ define TVHEADEND_INSTALL_INIT_SYSV
        $(INSTALL) -D package/tvheadend/S99tvheadend          $(TARGET_DIR)/etc/init.d/S99tvheadend
 endef
 
+define TVHEADEND_USERS
+tvheadend -1 tvheadend -1 * /home/tvheadend - video TVHeadend daemon
+endef
+
 #----------------------------------------------------------------------------
 # tvheadend is not an autotools-based package, but it is possible to
 # call its ./configure script as if it were an autotools one.