uboot-tools: do not override busybox uninstall commands
authorDanomi Manchego <danomimanchego123@gmail.com>
Wed, 12 Dec 2012 16:37:35 +0000 (16:37 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 13 Dec 2012 08:35:03 +0000 (09:35 +0100)
The uboot-tools.mk has a copy of BUSYBOX_UNINSTALL_TARGET_CMDS
in it, presumably due to a copy/paste error.  This definition
is overriding the (identical) definition in busybox.mk.

Also, add license info.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/uboot-tools/uboot-tools.mk

index 7628b77b8b0f3b53a9bc16622e2b095c61856174..75cda8e042f6ba1a29ae5e09ac9894a81ea18897 100644 (file)
@@ -1,6 +1,13 @@
+#############################################################
+#
+# uboot-tools
+#
+#############################################################
 UBOOT_TOOLS_VERSION = 2012.07
 UBOOT_TOOLS_SOURCE  = u-boot-$(UBOOT_TOOLS_VERSION).tar.bz2
 UBOOT_TOOLS_SITE    = ftp://ftp.denx.de/pub/u-boot
+UBOOT_TOOLS_LICENSE = GPLv2+
+UBOOT_TOOLS_LICENSE_FILES = COPYING
 
 define UBOOT_TOOLS_BUILD_CMDS
        $(MAKE) -C $(@D)                        \
@@ -34,11 +41,6 @@ define UBOOT_TOOLS_UNINSTALL_TARGET_CMDS
                usr/bin/mkimage usr/sbin/fw_printenv usr/sbin/fw_setenv)
 endef
 
-
-define BUSYBOX_UNINSTALL_TARGET_CMDS
-       $(BUSYBOX_MAKE_ENV) $(MAKE) $(BUSYBOX_MAKE_OPTS) -C $(@D) uninstall
-endef
-
 define HOST_UBOOT_TOOLS_BUILD_CMDS
        $(MAKE1) -C $(@D)                       \
                HOSTCC="$(HOSTCC)"              \