libnl: depend on host-bison
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 16 May 2011 12:43:51 +0000 (14:43 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 16 May 2011 12:43:51 +0000 (14:43 +0200)
libnl build breaks with bison <2.4 with:

bison -y -d  -o route/cls/ematch_syntax.c route/cls/ematch_syntax.y
route/cls/ematch_syntax.y:31.9-16: syntax error, unexpected
identifier, expecting string

So build our own known good version and use instead.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libnl/libnl.mk

index 767e957e5fd77903bef99b7899772354b69d42d1..8d3b9ade79f3fa0cbf5ad4d875ddfbd88c5dec79 100644 (file)
@@ -8,6 +8,7 @@ LIBNL_VERSION = 3.0
 LIBNL_SOURCE = libnl-$(LIBNL_VERSION).tar.gz
 LIBNL_SITE = http://www.infradead.org/~tgr/libnl/files/
 LIBNL_INSTALL_STAGING = YES
+LIBNL_DEPENDENCIES = host-bison
 
 define LIBNL_UNINSTALL_TARGET_CMDS
        rm -f $(TARGET_DIR)/usr/lib/libnl.so*