sl: new package
authorJens Rosenboom <j.rosenboom@x-ion.de>
Wed, 1 Apr 2015 09:08:45 +0000 (11:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Apr 2015 14:31:04 +0000 (16:31 +0200)
SL (Steam Locomotive) runs across your terminal when you type "sl" as
you meant to type "ls". It's just a joke command, and not useful at
all.

[Thomas:
 - Change "depends on BR2_PACKAGE_NCURSES" to "select
   BR2_PACKAGE_NCURSES".
 - Rewrap Config.in help text.
 - Remove comment in help text about the need to check dependencies,
   there's nothing to be done really.
 - Change the license from "Unclear" to "Custom".
 - Use $(TARGET_CONFIGURE_OPTS instead of passing CC and CFLAGS
   explicitly.
 - Pass '-m 0755' when doing the $(INSTALL)
 - Add ncurses to SL_DEPENDENCIES.]

Signed-off-by: Jens Rosenboom <j.rosenboom@x-ion.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/sl/Config.in [new file with mode: 0644]
package/sl/sl.mk [new file with mode: 0644]

index 4dd3ff296d5ca7c898b7324532a051fc569ffa92..ee4d476bd44a6f604485eeaf81eca54ffc177939 100644 (file)
@@ -184,6 +184,7 @@ menu "Games"
        source "package/opentyrian-data/Config.in"
        source "package/prboom/Config.in"
        source "package/rubix/Config.in"
+       source "package/sl/Config.in"
 endmenu
 
 menu "Fonts, icons, sounds and themes"
diff --git a/package/sl/Config.in b/package/sl/Config.in
new file mode 100644 (file)
index 0000000..7abe705
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_SL
+       bool "sl"
+       select BR2_PACKAGE_NCURSES
+       help
+         SL (Steam Locomotive) runs across your terminal when you
+         type "sl" as you meant to type "ls". It's just a joke
+         command, and not useful at all.
+
+         https://github.com/mtoyoda/sl
diff --git a/package/sl/sl.mk b/package/sl/sl.mk
new file mode 100644 (file)
index 0000000..bb28b2a
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# sl
+#
+################################################################################
+
+SL_VERSION = 5.02
+SL_SITE = $(call github,mtoyoda,sl,$(SL_VERSION))
+SL_LICENSE = Custom
+SL_LICENSE_FILES = LICENSE
+SL_DEPENDENCIES = ncurses
+
+define SL_BUILD_CMDS
+       $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
+endef
+
+define SL_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/sl $(TARGET_DIR)/usr/bin/sl
+endef
+
+$(eval $(generic-package))