php: openssl support needs to link against zlib for static linking
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 11 May 2015 15:37:46 +0000 (17:37 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 11 May 2015 15:37:46 +0000 (17:37 +0200)
Fixes:
http://autobuild.buildroot.net/results/490/490a9558635c90bf510b6f80cd0891fe322c3f46/
http://autobuild.buildroot.net/results/bf1/bf12eb189ab35ce00a2212695d2dbf8b8a126529/

Otherwise the configure script fails to detect openssl and bails out.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/php/php.mk

index 47811fff76ea23a375b4e3751cf4f365d742e3f8..279ebf8ecebed950e8b4052bc02bb6de5362f384 100644 (file)
@@ -109,6 +109,11 @@ endif
 ifeq ($(BR2_PACKAGE_PHP_EXT_OPENSSL),y)
 PHP_CONF_OPTS += --with-openssl=$(STAGING_DIR)/usr
 PHP_DEPENDENCIES += openssl
+# openssl needs zlib, but the configure script forgets to link against
+# it causing detection failures with static linking
+ifeq ($(BR2_STATIC_LIBS),y)
+PHP_CONF_ENV += LIBS='-lz'
+endif
 endif
 
 ifeq ($(BR2_PACKAGE_PHP_EXT_LIBXML2),y)