linphone: new package
authorLuca Ceresoli <luca@lucaceresoli.net>
Mon, 7 May 2012 10:43:12 +0000 (10:43 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 May 2012 20:58:41 +0000 (22:58 +0200)
Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/linphone/Config.in [new file with mode: 0644]
package/linphone/linphone.mk [new file with mode: 0644]

index ff03178c92e640b6f2866b126b442ed1638489ff..9a854f1c8048bd78c0a82efb244342d71e6d8f10 100644 (file)
@@ -524,6 +524,7 @@ if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/lighttpd/Config.in"
 endif
 source "package/links/Config.in"
+source "package/linphone/Config.in"
 source "package/lrzsz/Config.in"
 source "package/mii-diag/Config.in"
 source "package/mrouted/Config.in"
diff --git a/package/linphone/Config.in b/package/linphone/Config.in
new file mode 100644 (file)
index 0000000..31c28d8
--- /dev/null
@@ -0,0 +1,21 @@
+config BR2_PACKAGE_LINPHONE
+       bool "linphone"
+       select BR2_PACKAGE_LIBEXOSIP2
+       select BR2_PACKAGE_SPEEX
+       help
+         Linphone is an internet phone or Voice Over IP phone (VoIP).
+
+         With linphone you can communicate freely with people over
+         the internet, with voice, video, and text instant messaging.
+         Linphone makes use of the SIP protocol, an open standard
+         for internet telephony. You can use Linphone with any SIP
+         VoIP operator, including our free SIP audio/video service.
+         linphone is free-software (or open-source), you can download
+         and redistribute it freely.
+         Linphone is available for desktop computers: Linux, Windows,
+         MacOSX, and for mobile phones: Android, iPhone, Blackberry.
+
+         Linphone support in Buildroot is limited to the commandline
+         client, linphonec, and video support is not enabled.
+
+         http://www.linphone.org/
diff --git a/package/linphone/linphone.mk b/package/linphone/linphone.mk
new file mode 100644 (file)
index 0000000..6ba6b53
--- /dev/null
@@ -0,0 +1,12 @@
+#############################################################
+#
+# linphone
+#
+#############################################################
+
+LINPHONE_VERSION = 3.5.2
+LINPHONE_SITE = http://download-mirror.savannah.gnu.org/releases/linphone/3.5.x/sources/
+LINPHONE_CONF_OPT = --disable-video --disable-gtk_ui
+LINPHONE_DEPENDENCIES = libeXosip2 speex
+
+$(eval $(call AUTOTARGETS))