package/qemu: use autotools-package infrastructure
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 16 Dec 2012 06:52:37 +0000 (06:52 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 16 Dec 2012 19:13:23 +0000 (20:13 +0100)
Turns out that, with a little bit of tweaking, we can use
the autotools-package infrastructure to build QEMU.

That's better than defining all the _CMDS and using the
generic-package infra.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Francois Perrad <fperrad@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qemu/qemu.mk

index 315886f39f8d92115507b2823bc6e451502a3bcb..bd4248166944cd7f761d2ecb7cfb4cc865a4a9ae 100644 (file)
@@ -62,6 +62,9 @@ ifeq ($(HOST_QEMU_ARCH),powerpc)
 endif
 HOST_QEMU_TARGETS=$(HOST_QEMU_ARCH)-linux-user
 
+# Note: although QEMU has a ./configure script, it is not a real autotools
+# package, and ./configure chokes on options such as --host or --target.
+# So, provide out own _CONFIGURE_CMDS to override the defaults.
 define HOST_QEMU_CONFIGURE_CMDS
        (cd $(@D); $(HOST_CONFIGURE_OPTS) ./configure   \
                --target-list="$(HOST_QEMU_TARGETS)"    \
@@ -74,19 +77,7 @@ define HOST_QEMU_CONFIGURE_CMDS
        )
 endef
 
-define HOST_QEMU_BUILD_CMDS
-       $(MAKE) -C $(@D) all
-endef
-
-define HOST_QEMU_INSTALL_CMDS
-       $(MAKE) -C $(@D) install
-endef
-
-define HOST_QEMU_CLEAN_CMDS
-       $(MAKE) -C $(@D) clean
-endef
-
-$(eval $(host-generic-package))
+$(eval $(host-autotools-package))
 
 # variable used by other packages
 QEMU_USER = $(HOST_DIR)/usr/bin/qemu-$(HOST_QEMU_ARCH)