package/c-icap: add optional support for openssl
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 May 2017 21:41:24 +0000 (23:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 May 2017 13:40:34 +0000 (15:40 +0200)
Optional OpenSSL was added with version 0.5.1:
https://sourceforge.net/p/c-icap/news/2017/03/the-c-icap-051-is-released-/
https://sourceforge.net/p/c-icap/code/1253/#diff-5

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/c-icap/c-icap.mk

index 82b257406dde706c98e6629bb6520423fce8f8b1..e57ecd0ae0f1996b57610dd5ffd6963e1cc011b0 100644 (file)
@@ -54,6 +54,13 @@ else
 C_ICAP_CONF_OPTS += --without-ldap
 endif
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+C_ICAP_CONF_OPTS += --with-openssl
+C_ICAP_DEPENDENCIES += openssl
+else
+C_ICAP_CONF_OPTS += --without-openssl
+endif
+
 ifeq ($(BR2_PACKAGE_PCRE),y)
 C_ICAP_CONF_OPTS += --with-pcre
 C_ICAP_DEPENDENCIES += pcre