package/links: add optional support for gpm
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 20 Feb 2016 17:09:01 +0000 (18:09 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 13:59:44 +0000 (14:59 +0100)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/links/links.mk

index def7b7590a2a7092497e682fe643f3536fd1e34d..62f91a32e39e1621edadec581f002b6b22c6efc8 100644 (file)
@@ -56,6 +56,13 @@ else
 LINKS_CONF_OPTS += --without-bzip2
 endif
 
+ifeq ($(BR2_PACKAGE_GPM),y)
+LINKS_CONF_OPTS += --with-gpm
+LINKS_DEPENDENCIES += gpm
+else
+LINKS_CONF_OPTS += --without-gpm
+endif
+
 ifeq ($(BR2_PACKAGE_LIBEVENT),y)
 LINKS_CONF_OPTS += --with-libevent
 LINKS_DEPENDENCIES += libevent