dtc: install libfdt library and headers for host variant
authorDavid Raeman <draeman@bbn.com>
Mon, 25 Jul 2016 19:52:27 +0000 (15:52 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 25 Jul 2016 22:01:14 +0000 (00:01 +0200)
The dtc package currently does not install libfdt for the host install.
It can be useful to have libfdt on the host, such as for building QEMU
with the --enable-fdt configure switch.

Signed-off-by: David Raeman <draeman@bbn.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dtc/dtc.mk

index 8fdcdbed7766ea5c29f1546ba45a2bcbd3965db9..febd5920ce0632d51e6ef5085c6c6e868435f5f9 100644 (file)
@@ -51,7 +51,9 @@ define HOST_DTC_BUILD_CMDS
 endef
 
 define HOST_DTC_INSTALL_CMDS
-       $(MAKE) -C $(@D) PREFIX=$(HOST_DIR)/usr install-bin
+       $(MAKE) -C $(@D) PREFIX=$(HOST_DIR)/usr install-bin install-lib \
+               install-includes
+
 endef
 
 $(eval $(generic-package))