package/uclibc: default to Y for IPv6
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 19 Apr 2015 12:39:53 +0000 (09:39 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Apr 2015 20:59:20 +0000 (22:59 +0200)
Remove the option to disable IPv6 support in uclibc and associated
logic.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uclibc/Config.in
package/uclibc/uclibc.mk

index a48e2ec38325f35011cd7149e6861f05bad4a63d..51a1668acb15cec3ad091b3d12ac6ec59393d836 100644 (file)
@@ -87,11 +87,9 @@ config BR2_UCLIBC_CONFIG
          If unsure, use the default.
 
 config BR2_TOOLCHAIN_BUILDROOT_INET_IPV6
-       bool "Enable IPv6 support"
+       bool
        select BR2_INET_IPV6
-       help
-         Enable this option if you want your toolchain to support
-         IPv6.
+       default y
 
 config BR2_TOOLCHAIN_BUILDROOT_INET_RPC
        bool "Enable RPC support"
index 72a46d963bcfb95cda566f1ec5a768394a89df2a..07ff8e5311ebe3028c80f5b336fd9bb72d17c60f 100644 (file)
@@ -212,11 +212,7 @@ endif
 # IPv6
 #
 
-ifeq ($(BR2_TOOLCHAIN_BUILDROOT_INET_IPV6),y)
 UCLIBC_IPV6_CONFIG = $(call KCONFIG_ENABLE_OPT,UCLIBC_HAS_IPV6,$(@D)/.config)
-else
-UCLIBC_IPV6_CONFIG = $(call KCONFIG_DISABLE_OPT,UCLIBC_HAS_IPV6,$(@D)/.config)
-endif
 
 #
 # RPC