toolchain-external: add Sourcery CodeBench MIPS 2011.09
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 3 Jun 2012 14:04:40 +0000 (16:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Jul 2012 15:29:37 +0000 (17:29 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index f53ec8874928d7953fd33bf6dcf0aa527e38fe41..5c29ecd0b13929d89061327d620caa7265406905 100644 (file)
@@ -161,6 +161,73 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2010Q1
               Select BR2_SOFT_FLOAT
               Set BR2_TARGET_OPTIMIZATION to -mthumb
 
+config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201109
+       bool "Sourcery CodeBench MIPS 2011.09"
+       depends on BR2_mips || BR2_mipsel
+       select BR2_TOOLCHAIN_EXTERNAL_GLIBC
+       select BR2_INSTALL_LIBSTDCPP
+       help
+         Sourcery CodeBench toolchain for the MIPS architecture, from
+         Mentor Graphics. It uses gcc 4.5.2, binutils 2.21.53, glibc
+         2.13, uClibc 0.9.30 and gdb 7.2.50, kernel headers
+         3.0.1. It has support for the following variants:
+           - MIPS32 O32 big endian glibc
+             Select a MIPS generic core
+             Disable BR2_SOFT_FLOAT
+           - MIPS64 big endian glibc
+             Select a MIPS generic core
+             Select the n64 ABI
+             Disable BR2_SOFT_FLOAT
+           - MIPS32 O32 little endian glibc
+             Select a MIPS generic core
+             Disable BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -EL
+           - MIPS64 little endian glibc
+             Select a MIPS generic core
+             Select the n64 ABI
+             Disable BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -EL
+           - MIPS32 big endian soft float glibc
+             Select a MIPS generic core
+             Select BR2_SOFT_FLOAT
+           - MIPS64 big endian soft float glibc
+             Select a MIPS generic core
+             Select the n64 ABI
+             Select BR2_SOFT_FLOAT
+           - MIPS32 little endian soft float glibc
+             Select a MIPS generic core
+             Select BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -EL
+           - MIPS64 little endian soft float glibc
+             Select a MIPS generic core
+             Select the n64 ABI
+             Select BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -EL
+           - MIPS32 big endian microMIPS glibc
+             Select a MIPS generic core
+             Disable BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -mips16
+           - MIPS32 little endian microMIPS glibc
+             Select a MIPS generic core
+             Disable BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -EL -mips16
+           - MIPS32 big endian soft float microMIPS glibc
+             Select a MIPS generic core
+             Select BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -mips16
+           - MIPS32 little endian soft float microMIPS glibc
+             Select a MIPS generic core
+             Select BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -EL -mips16
+           - MIPS32 big endian uclibc
+             Not usable in Buildroot yet.
+           - MIPS32 little endian uclibc
+             Not usable in Buildroot yet.
+           - MIPS32 big endian soft float uclibc
+             Not usable in Buildroot yet.
+           - MIPS32 little endian soft float uclibc
+             Not usable in Buildroot yet.
+
 config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201103
        bool "Sourcery CodeBench MIPS 2011.03"
        depends on BR2_mips || BR2_mipsel
@@ -555,6 +622,7 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        default "microblaze-unknown-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEBE_V2
        default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44
        default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201103
+       default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201109
        default "powerpc-linux-gnu"      if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201009
        default "powerpc-linux-gnu"      if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201103
        default "sh-linux-gnu"           if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_SH201009
index 388eccc33ea6856f4dd4e03f9ae346031a77f0ae..53b898f3f3c847f155ea98974f2e0bc982206b62 100644 (file)
@@ -208,6 +208,9 @@ TOOLCHAIN_EXTERNAL_SOURCE=mips-4.4-303-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201103),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/mips/portal/package9469/public/mips-linux-gnu/
 TOOLCHAIN_EXTERNAL_SOURCE=mips-2011.03-110-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201109),y)
+TOOLCHAIN_EXTERNAL_SITE=https://sourcery.mentor.com/GNUToolchain/package9761/public/mips-linux-gnu/
+TOOLCHAIN_EXTERNAL_SOURCE=mips-2011.09-75-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201009),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/power/portal/package7703/public/powerpc-linux-gnu/
 TOOLCHAIN_EXTERNAL_SOURCE=freescale-2010.09-55-powerpc-linux-gnu-i686-pc-linux-gnu.tar.bz2