comparing $(ARCH) vs i.e. i386 isn't going to work when ARCH=i486 etc.
authorEric Andersen <andersen@codepoet.org>
Thu, 10 Aug 2006 20:58:14 +0000 (20:58 -0000)
committerEric Andersen <andersen@codepoet.org>
Thu, 10 Aug 2006 20:58:14 +0000 (20:58 -0000)
Need to instead compare vs BR2_i386 and friends.

package/portage/portage.mk

index 94fd1b455d403051d04e0ef52990c7c649072f24..38552b31e78da08bb1cbda532ec71009560d6798 100644 (file)
@@ -18,22 +18,22 @@ SANDBOX_CAT:=$(PORTAGE_CAT)
 SANDBOX_DIR:=$(BUILD_DIR)/sandbox-$(SANDBOX_VERSION)
 SANDBOX_TARGET_BINARY:=usr/bin/sandbox
 
-ifeq ($(ARCH),cris)
+ifeq ($(BR2_cris),y)
        PORTAGE_ARCH:=x86
 endif
-ifeq ($(ARCH), mipsel)
+ifeq ($(BR2_mipsel),y)
        PORTAGE_ARCH:=mips
 endif
-ifeq ($(ARCH), powerpc)
+ifeq ($(BR2_powerpc),y)
        PORTAGE_ARCH:=ppc
 endif
-ifeq ($(ARCH),sh4)
+ifeq ($(BR2_sh4),y)
        PORTAGE_ARCH:=sh
 endif
-ifeq ($(ARCH),sh64)
+ifeq ($(BR2_sh64),y)
        PORTAGE_ARCH:=sh
 endif
-ifeq ($(ARCH), i386)
+ifeq ($(BR2_i386),y)
        PORTAGE_ARCH:=x86
 endif
 ifeq ($(PORTAGE_ARCH),)