xscreensaver: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 21:25:22 +0000 (23:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:36:54 +0000 (01:36 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xscreensaver/Config.in
package/xscreensaver/xscreensaver.mk

index 5213ce369563d98b440121d436577d5b174db854..032eab2ae3f6cc67fa4203d59130a1771f4f116e 100644 (file)
@@ -11,7 +11,6 @@ config BR2_PACKAGE_XSCREENSAVER
        select BR2_PACKAGE_JPEG
        select BR2_PACKAGE_XLIB_LIBX11
        select BR2_PACKAGE_XLIB_LIBXT
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          XScreenSaver is the standard screen saver collection shipped on most
          Linux and Unix systems running the X11 Window System.
index 77c37a9e98d514c1f5c8985d5288c67d47e62a34..34b116387bf40f8fa4e9d6d5e10c7d052d267710 100644 (file)
@@ -12,7 +12,7 @@ XSCREENSAVER_LICENSE = MIT-like, GPL-2.0+
 XSCREENSAVER_LICENSE_FILES = hacks/screenhack.h hacks/glx/chessmodels.h
 
 XSCREENSAVER_DEPENDENCIES = jpeg libglade libgtk2 xlib_libX11 xlib_libXt \
-       $(if $(BR2_PACKAGE_GETTEXT),gettext) host-intltool
+       $(TARGET_NLS_DEPENDENCIES) host-intltool
 
 # otherwise we end up with host include/library dirs passed to the
 # compiler/linker