- fix some whitespace damage..
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 5 Oct 2007 12:55:40 +0000 (12:55 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 5 Oct 2007 12:55:40 +0000 (12:55 -0000)
- add COPYTO settings for cpio and tar and remove that ugly hardcoded DATE from that was added by Ulf

package/Makefile.in
target/cpio/Config.in
target/cpio/cpioroot.mk
target/ext2/Config.in
target/jffs2/Config.in
target/linux/Config.in
target/tar/Config.in
target/tar/tarroot.mk

index 903f46d6d6541af02d2df49f2e7a2a2879f473bf..f16746060e3d4f4bff962763e3c6de28bdedaba4 100644 (file)
@@ -72,7 +72,7 @@ TOOL_BUILD_DIR=$(BASE_DIR)/$(TOPDIR_PREFIX)toolchain_build_$(ARCH)$(ARCH_FPU_SUF
 
 # Quotes are needed for spaces et al in path components.
 TARGET_PATH="$(TOOL_BUILD_DIR)/bin:$(STAGING_DIR)/bin:$(STAGING_DIR)/usr/bin:$(PATH)"
-IMAGE:=$(BINARIES_DIR)/rootfs.$(ARCH)$(ARCH_FPU_SUFFIX)-$(DATE)
+IMAGE:=$(BINARIES_DIR)/rootfs.$(ARCH)$(ARCH_FPU_SUFFIX)
 GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux
 REAL_GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)$(GNU_TARGET_SUFFIX)
 TARGET_CROSS=$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-
index 496a4da0fb914dda9bbefa34b9ce7d74e41c1237..3f25cc60bf532e4c6559c647e5c918f6fc8b5322 100644 (file)
@@ -40,3 +40,12 @@ config BR2_TARGET_ROOTFS_CPIO_LZMA
 
 endchoice
 
+config BR2_TARGET_ROOTFS_CPIO_COPYTO
+       string "also copy the image to..."
+       depends on BR2_TARGET_ROOTFS_CPIO
+       default ""
+       help
+         Copies the resulting image to a secondary location
+         like a tftp server's root directory.
+         
+         Example: $(IMAGE)-$(DATE).cpio$(CPIO_ROOTFS_COMPRESSOR_EXT)
index 3a8d03a0f3a6a2d20450999fbdf090fa71d25612..c18261e27a92a04948aaffc74255e178a62c981e 100644 (file)
@@ -31,6 +31,9 @@ else
 CPIO_TARGET := $(CPIO_BASE)
 endif
 
+ROOTFS_CPIO_COPYTO:=$(strip $(subst ",,$(BR2_TARGET_ROOTFS_CPIO_COPYTO)))
+# "))
+#
 
 cpioroot-init:
        rm -f $(TARGET_DIR)/init
@@ -61,10 +64,18 @@ endif
        chmod a+x $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
        $(STAGING_DIR)/usr/bin/fakeroot -- $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
        #-@rm -f $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
+ifeq ($(CPIO_ROOTFS_COMPRESSOR),)
+ifneq ($(ROOTFS_CPIO_COPYTO),)
+       $(Q)cp -f $(CPIO_BASE) $(ROOTFS_CPIO_COPYTO)
+endif
+endif
 
 ifneq ($(CPIO_ROOTFS_COMPRESSOR),)
 $(CPIO_BASE).$(CPIO_ROOTFS_COMPRESSOR_EXT): $(CPIO_ROOTFS_COMPRESSOR_PREREQ) $(CPIO_BASE)
        $(CPIO_ROOTFS_COMPRESSOR) $(CPIO_BASE) > $(CPIO_TARGET)
+ifneq ($(ROOTFS_CPIO_COPYTO),)
+       $(Q)cp -f $(CPIO_BASE).$(CPIO_ROOTFS_COMPRESSOR_EXT) $(ROOTFS_CPIO_COPYTO).$(CPIO_ROOTFS_COMPRESSOR_EXT)
+endif
 endif
 
 cpioroot: $(CPIO_TARGET)
index fa0575ac6bbf4360073b99b168fefde84019d05c..e94fb401c373967678b721a6357745ebf83f182a 100644 (file)
@@ -8,12 +8,12 @@ config BR2_TARGET_ROOTFS_EXT2
 config BR2_TARGET_ROOTFS_EXT2_BLOCKS
        int "size in blocks (leave at 0 for auto calculation)"
        depends on BR2_TARGET_ROOTFS_EXT2
-       default 0
+       default 0
 
 config BR2_TARGET_ROOTFS_EXT2_INODES
        int "inodes (leave at 0 for auto calculation)"
        depends on BR2_TARGET_ROOTFS_EXT2
-       default 0
+       default 0
 
 config BR2_TARGET_ROOTFS_EXT2_RESBLKS
        int "reserved blocks percentage"
@@ -22,7 +22,7 @@ config BR2_TARGET_ROOTFS_EXT2_RESBLKS
 
 config BR2_TARGET_ROOTFS_EXT2_SQUASH
        bool "Make all files be owned by root"
-       depends on      BR2_TARGET_ROOTFS_EXT2
+       depends on  BR2_TARGET_ROOTFS_EXT2
        default y
 
 config BR2_TARGET_ROOTFS_EXT2_OUTPUT
@@ -31,44 +31,45 @@ config BR2_TARGET_ROOTFS_EXT2_OUTPUT
        default "$(IMAGE).ext2"
 
 choice
-        prompt "Compression method"
-        default BR2_TARGET_ROOTFS_EXT2_NONE
-        depends on BR2_TARGET_ROOTFS_EXT2
-        help
-          Select compressor for ext2 filesystem of the root filesystem
+       prompt "Compression method"
+       default BR2_TARGET_ROOTFS_EXT2_NONE
+       depends on BR2_TARGET_ROOTFS_EXT2
+       help
+         Select compressor for ext2 filesystem of the root filesystem
 
 config BR2_TARGET_ROOTFS_EXT2_NONE
-        bool "no compression"
-        help
-         Do not compress the ext2 filesystem.
+       bool "no compression"
+       help
+         Do not compress the ext2 filesystem.
 
 config BR2_TARGET_ROOTFS_EXT2_GZIP
-        bool "gzip"
-        help
-         Do compress the ext2 filesystem with gzip.
-         Note that you either have to have gzip installed on your host
-         or select to build a gzip for your host. See the packages submenu.
+       bool "gzip"
+       help
+         Do compress the ext2 filesystem with gzip.
+         Note that you either have to have gzip installed on your host
+         or select to build a gzip for your host. See the packages submenu.
 
 config BR2_TARGET_ROOTFS_EXT2_BZIP2
-        bool "bzip2"
-        help
-         Do compress the ext2 filesystem with bzip2.
-         Note that you either have to have bzip2 installed on your host
-         or select to build a bzip2 for your host. See the packages submenu.
+       bool "bzip2"
+       help
+         Do compress the ext2 filesystem with bzip2.
+         Note that you either have to have bzip2 installed on your host
+         or select to build a bzip2 for your host. See the packages submenu.
 
 config BR2_TARGET_ROOTFS_EXT2_LZMA
-        bool "lzma"
-        help
-         Do compress the ext2 filesystem with lzma.
-         Note that you either have to have lzma installed on your host
-         or select to build a lzma for your host. See the packages submenu.
+       bool "lzma"
+       help
+         Do compress the ext2 filesystem with lzma.
+         Note that you either have to have lzma installed on your host
+         or select to build a lzma for your host. See the packages submenu.
 
 endchoice
 
 config BR2_TARGET_ROOTFS_EXT2_COPYTO
        string "also copy the image to..."
-       depends on      BR2_TARGET_ROOTFS_EXT2
+       depends on BR2_TARGET_ROOTFS_EXT2
        default ""
        help
          Copies the resulting image to a secondary location
          like a tftp server's root directory.
+
index 35fa4987d13dc6c23a0a2cb51ea55ead41d902b2..268c1916f3ec9161d3e6be4c7386700934450f9c 100644 (file)
@@ -49,7 +49,7 @@ config BR2_TARGET_ROOTFS_JFFS2_EBSIZE
        default 0x2100
 
 config BR2_TARGET_ROOTFS_JFFS2_NOCLEANMARKER
-       bool    "Do not use Cleanmarker"
+       bool "Do not use Cleanmarker"
        depends on BR2_TARGET_ROOTFS_JFFS2
        default n
        help
@@ -79,17 +79,17 @@ choice
 
 config BR2_TARGET_ROOTFS_JFFS2_LE
        bool "little-endian"
-       depends on      BR2_TARGET_ROOTFS_JFFS2
+       depends on BR2_TARGET_ROOTFS_JFFS2
 
 config BR2_TARGET_ROOTFS_JFFS2_BE
        bool "big-endian"
-       depends on      BR2_TARGET_ROOTFS_JFFS2
+       depends on BR2_TARGET_ROOTFS_JFFS2
 
 endchoice
 
 config BR2_TARGET_ROOTFS_JFFS2_SQUASH
        bool "Make all files be owned by root"
-       depends on      BR2_TARGET_ROOTFS_JFFS2
+       depends on BR2_TARGET_ROOTFS_JFFS2
 
 config BR2_TARGET_ROOTFS_JFFS2_OUTPUT
        string "Output File"
@@ -98,7 +98,7 @@ config BR2_TARGET_ROOTFS_JFFS2_OUTPUT
 
 config BR2_TARGET_ROOTFS_JFFS2_COPYTO
        string "also copy the image to..."
-       depends on      BR2_TARGET_ROOTFS_JFFS2
+       depends on BR2_TARGET_ROOTFS_JFFS2
        default ""
        help
          Copies the resulting image to a secondary location.
index f045e7566b6a8b9b82ab0752bf0f038b7cd9062b..7e3064b86b8489939ee955b61432a793a689be4c 100644 (file)
@@ -10,7 +10,7 @@ config BR2_PACKAGE_LINUX
 
          Note: Requires kernel-headers >= 2.6.19 since the other
                kernel headers are just that (headers) and not full
-               kernels. This is a feature.
+               kernels. This is a feature.
 
 config BR2_PACKAGE_LINUX_EXPERIMENTAL_CONFIG
        bool "linux kernel experimental configuration"
index 4787ec09416fd287a3279f96029407567ac714cd..03f9330cd93da7cb9df195bb939c5daa6f406cc5 100644 (file)
@@ -48,3 +48,13 @@ config BR2_TARGET_ROOTFS_TAR_OPTIONS
          Any other flags you want to pass to tar
          Refer to tar --help for details
 
+config BR2_TARGET_ROOTFS_TAR_COPYTO
+       string "also copy the image to..."
+       depends on BR2_TARGET_ROOTFS_TAR
+       default ""
+       help
+         Copies the resulting image to a secondary location
+         like a tftp server's root directory.
+
+         Example: $(IMAGE)-$(DATE).tar
+
index 913cf82a18494d91a6f873ba63d72394ee3c9a8b..b47259e2ddebe7cf7641e9d3af6da391f804041a 100644 (file)
@@ -21,6 +21,8 @@ ifeq ($(BR2_TARGET_ROOTFS_TAR_LZMA),y)
 TAR_COMPRESSOR:=lzma -9 -c
 TAR_COMPRESSOR_EXT:=lzma
 endif
+ROOTFS_TAR_COPYTO:=$(strip $(subst ",,$(BR2_TARGET_ROOTFS_TAR_COPYTO)))
+# "))
 
 tarroot: host-fakeroot makedevs
        -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIPCMD) 2>/dev/null || true
@@ -49,9 +51,16 @@ endif
 ifneq ($(TAR_COMPRESSOR),)
        -rm -f $(TAR_TARGET).$()
        PATH="$(STAGING_DIR)/sbin:$(STAGING_DIR)/bin:$(STAGING_DIR)/usr/sbin:$(STAGING_DIR)/usr/bin:$(PATH)" $(TAR_COMPRESSOR) $(TAR_TARGET) > $(TAR_TARGET).$(TAR_COMPRESSOR_EXT)
+endif
+ifneq ($(ROOTFS_TAR_COPYTO),)
+       $(Q)cp -f $(TAR_TARGET) $(ROOTFS_TAR_COPYTO)
 endif
        -@rm -f $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
 
+EXT2_COPYTO := $(strip $(subst ",,$(BR2_TARGET_ROOTFS_EXT2_COPYTO)))
+# "))
+
+
 tarroot-source:
 
 tarroot-clean: