package/pkg-meson.mk: set correct pkgconfig for native dependencies
authorJames Hilliard <james.hilliard1@gmail.com>
Tue, 28 Apr 2020 12:22:12 +0000 (06:22 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 1 May 2020 14:01:29 +0000 (16:01 +0200)
This sets the correct build.pkg_config_path for all meson packages so
that dependencies with native: true will properly use the the host
pkgconfig instead of the target pkgconfig.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-meson.mk

index 2ba10f30ed6bb1f13b8b05a1b044803a91b4b7be..0a4ab2194c43cd4aeaffdd0f19e432034098c189 100644 (file)
@@ -87,6 +87,7 @@ define $(2)_CONFIGURE_CMDS
                --default-library=$(if $(BR2_STATIC_LIBS),static,shared) \
                --buildtype=$(if $(BR2_ENABLE_DEBUG),debug,release) \
                --cross-file=$$($$(PKG)_SRCDIR)/build/cross-compilation.conf \
+               -Dbuild.pkg_config_path=$$(HOST_DIR)/lib/pkgconfig \
                $$($$(PKG)_CONF_OPTS) \
                $$($$(PKG)_SRCDIR) $$($$(PKG)_SRCDIR)/build
 endef