package/glibc: allow to specify host-make
authorRomain Naour <romain.naour@gmail.com>
Mon, 3 Sep 2018 19:19:33 +0000 (21:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 8 Sep 2018 21:36:36 +0000 (23:36 +0200)
Use host-make package if GNU make from the host machine is too old.

Use the newly introduced BR2_MAKE_HOST_DEPENDENCY and BR2_MAKE to
provide respectively, host-make dependency and the path to the GNU
make binary to use for building glibc.

Fixes:
http://autobuild.buildroot.net/results/576/5760ea2635d9aecc9c789494a8b2cc73a1af1ceb
http://autobuild.buildroot.net/results/583/58347b94884eee2db28740486eda280e8c08e22f
http://autobuild.buildroot.net/results/dc7/dc7c8cd548409864ab0055e196c0280457a5fb5f

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Baruch Siach <baruch@tkos.co.il>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Tested-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/glibc/glibc.mk

index 399cf395cee6c72bc16453dcfae93c0b4f2694f6..a2eb8714b198d92f9dabb5956f7443d7b7186eb4 100644 (file)
@@ -28,7 +28,12 @@ GLIBC_ADD_TOOLCHAIN_DEPENDENCY = NO
 
 # Before glibc is configured, we must have the first stage
 # cross-compiler and the kernel headers
-GLIBC_DEPENDENCIES = host-gcc-initial linux-headers host-bison host-gawk
+GLIBC_DEPENDENCIES = host-gcc-initial linux-headers host-bison host-gawk \
+       $(BR2_MAKE_HOST_DEPENDENCY)
+
+# glibc requires make >= 4.0 since 2.28 release.
+# https://www.sourceware.org/ml/libc-alpha/2018-08/msg00003.html
+GLIBC_MAKE = $(BR2_MAKE)
 
 GLIBC_SUBDIR = build