ruby: disable openssl for host variant
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 22 May 2014 18:04:28 +0000 (15:04 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 22 May 2014 21:38:30 +0000 (23:38 +0200)
As reported by Fatih Aşıcı on the mailing list it sometimes fails with
the host openssl depending on versions when development files are
installed.
And as suggested by Thomas Petazzoni it's really not required for
anything so just disable it.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ruby/ruby.mk

index 0ea352d7cc82385dc1b1817404adde1401df8988..65a59f5509aa5eb62c88f32060d8c0d79f26c281 100644 (file)
@@ -12,7 +12,8 @@ HOST_RUBY_DEPENDENCIES = host-pkgconf
 RUBY_MAKE_ENV = $(TARGET_MAKE_ENV)
 RUBY_MAKE = $(MAKE1)
 RUBY_CONF_OPT = --disable-install-doc --disable-rpath
-HOST_RUBY_CONF_OPT = --disable-install-doc --with-out-ext=curses,readline
+HOST_RUBY_CONF_OPT = --disable-install-doc \
+       --with-out-ext=curses,openssl,readline
 RUBY_LICENSE = Ruby or BSD-2c, BSD-3c, others
 RUBY_LICENSE_FILES = LEGAL COPYING BSDL