xconsole: add new package
authorYegor Yefremov <yegorslists@googlemail.com>
Fri, 13 Dec 2013 08:13:32 +0000 (09:13 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 15 Dec 2013 20:05:44 +0000 (21:05 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/x11r7/Config.in
package/x11r7/xapp_xconsole/Config.in [new file with mode: 0644]
package/x11r7/xapp_xconsole/xapp_xconsole.mk [new file with mode: 0644]

index 15e2f8b67181e403b0132d76dac0d1a76ea41770..fe0674c7835a77ffa6683a885bf86c1132aad410 100644 (file)
@@ -88,6 +88,7 @@ if BR2_PACKAGE_XORG7
                source package/x11r7/xapp_xclipboard/Config.in
                source package/x11r7/xapp_xclock/Config.in
                source package/x11r7/xapp_xcmsdb/Config.in
+               source package/x11r7/xapp_xconsole/Config.in
                source package/x11r7/xapp_xcursorgen/Config.in
                source package/x11r7/xapp_xdbedizzy/Config.in
                source package/x11r7/xapp_xditview/Config.in
diff --git a/package/x11r7/xapp_xconsole/Config.in b/package/x11r7/xapp_xconsole/Config.in
new file mode 100644 (file)
index 0000000..7863afd
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_XAPP_XCONSOLE
+       bool "xconsole"
+       select BR2_PACKAGE_XLIB_LIBX11
+       select BR2_PACKAGE_XLIB_LIBXAW
+       select BR2_PACKAGE_XLIB_LIBXT
+       select BR2_PACKAGE_XPROTO_XPROTO
+       select BR2_PACKAGE_XLIB_LIBXMU
+       help
+         xconsole - monitor system console messages with X
diff --git a/package/x11r7/xapp_xconsole/xapp_xconsole.mk b/package/x11r7/xapp_xconsole/xapp_xconsole.mk
new file mode 100644 (file)
index 0000000..b04b737
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# xapp_xconsole
+#
+################################################################################
+
+XAPP_XCONSOLE_VERSION = 1.0.6
+XAPP_XCONSOLE_SOURCE = xconsole-$(XAPP_XCONSOLE_VERSION).tar.bz2
+XAPP_XCONSOLE_SITE = http://xorg.freedesktop.org/releases/individual/app
+XAPP_XCONSOLE_LICENSE = MIT
+XAPP_XCONSOLE_LICENSE_FILES = COPYING
+XAPP_XCONSOLE_DEPENDENCIES = xlib_libX11 xlib_libXaw xlib_libXt xproto_xproto \
+                            xlib_libXmu
+
+$(eval $(autotools-package))