package/thermald: fix build with NLS
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 19 Jan 2020 10:19:31 +0000 (11:19 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 3 Feb 2020 10:11:38 +0000 (11:11 +0100)
Fixes:
 - http://autobuild.buildroot.org/results/609e304d2874f39cbb6258ee185610332a1031f2

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Tested-by: Ricardo Martincoski <ricardo.martincoski@datacom.com.br>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/thermald/thermald.mk

index ace4eed8e37e47bbfc7bae3e3e250efafa8811bf..98e9c361e55c6b83da372f60f062ace971f8eb35 100644 (file)
@@ -8,10 +8,11 @@ THERMALD_VERSION = 1.9.1
 THERMALD_SITE = $(call github,intel,thermal_daemon,v$(THERMALD_VERSION))
 # fetched from Github, with no configure script
 THERMALD_AUTORECONF = YES
-THERMALD_DEPENDENCIES = dbus dbus-glib libxml2
+THERMALD_DEPENDENCIES = dbus dbus-glib libxml2 $(TARGET_NLS_DEPENDENCIES)
 # tools are GPL-3.0+ but are not added to the target
 THERMALD_LICENSE = GPL-2.0+
 THERMALD_LICENSE_FILES = COPYING
+THERMALD_CONF_ENV = LIBS=$(TARGET_NLS_LIBS)
 
 ifeq ($(BR2_INIT_SYSTEMD),y)
 THERMALD_DEPENDENCIES += systemd