util-linux: bump to version 2.24.2
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 29 Apr 2014 13:22:54 +0000 (10:22 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 29 Apr 2014 21:10:45 +0000 (23:10 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/util-linux/util-linux-003-c.h-define-mkostemp-for-older-version-of-uClibc.patch [new file with mode: 0644]
package/util-linux/util-linux-003-unshare-include-libmount.h.patch [deleted file]
package/util-linux/util-linux-004-c.h-define-mkostemp-for-older-version-of-uClibc.patch [deleted file]
package/util-linux/util-linux.mk

diff --git a/package/util-linux/util-linux-003-c.h-define-mkostemp-for-older-version-of-uClibc.patch b/package/util-linux/util-linux-003-c.h-define-mkostemp-for-older-version-of-uClibc.patch
new file mode 100644 (file)
index 0000000..0dfe7be
--- /dev/null
@@ -0,0 +1,50 @@
+From 42a84250fc78bae3e885ecd1379e713663fe6487 Mon Sep 17 00:00:00 2001
+From: Romain Naour <romain.naour@openwide.fr>
+Date: Sun, 6 Apr 2014 12:12:41 +0200
+Subject: [PATCH 1/1] c.h: define mkostemp for older version of uClibc
+
+Signed-off-by: Romain Naour <romain.naour@openwide.fr>
+---
+ configure.ac |  2 ++
+ include/c.h  | 14 ++++++++++++++
+ 2 files changed, 16 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 35a1f26..a9b8d34 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -321,6 +321,8 @@ AC_CHECK_FUNCS([ \
+ ])
+ AC_FUNC_FSEEKO
++AC_CHECK_FUNCS([mkostemp])
++
+ AC_CHECK_FUNCS([openat fstatat unlinkat], [have_openat=yes], [have_openat=no])
+ AC_CHECK_FUNCS([ioperm iopl], [have_io=yes])
+diff --git a/include/c.h b/include/c.h
+index 4a9bf3d..1b880ed 100644
+--- a/include/c.h
++++ b/include/c.h
+@@ -300,4 +300,18 @@ static inline int usleep(useconds_t usec)
+ # define SEEK_HOLE    4
+ #endif
++/*
++ * mkostemp() may be missing with older version of uClibc
++ */
++#ifndef HAVE_MKOSTEMP
++static inline int mkostemp(char *template, int flags)
++{
++      int fd;
++      fd = mkstemp(template);
++      if (flags & O_CLOEXEC && fd >= 0)
++              fcntl(fd, F_SETFD, FD_CLOEXEC);
++      return fd;
++}
++#endif
++
+ #endif /* UTIL_LINUX_C_H */
+-- 
+1.9.0
+
diff --git a/package/util-linux/util-linux-003-unshare-include-libmount.h.patch b/package/util-linux/util-linux-003-unshare-include-libmount.h.patch
deleted file mode 100644 (file)
index 5ccfe7d..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-From d754315c54af9cb8222e0a04ed5b2b4b927ed176 Mon Sep 17 00:00:00 2001
-From: Ruediger Meier <ruediger.meier@ga-group.nl>
-Date: Mon, 17 Mar 2014 11:48:47 +0100
-Subject: [PATCH 1/1] unshare: include libmount.h to provide missing MS_*
- defines
-
-Since 6728ca10 we are using MS_PRIVATE and MS_REC which are not defined
-in some systems's sys/mount.h.
-
-Signed-off-by: Ruediger Meier <ruediger.meier@ga-group.nl>
----
- sys-utils/Makemodule.am | 1 +
- sys-utils/unshare.c     | 3 +++
- 2 files changed, 4 insertions(+)
-
-diff --git a/sys-utils/Makemodule.am b/sys-utils/Makemodule.am
-index 30b5d3e..93a2c8d 100644
---- a/sys-utils/Makemodule.am
-+++ b/sys-utils/Makemodule.am
-@@ -296,6 +296,7 @@ usrbin_exec_PROGRAMS += unshare
- dist_man_MANS += sys-utils/unshare.1
- unshare_SOURCES = sys-utils/unshare.c
- unshare_LDADD = $(LDADD) libcommon.la
-+unshare_CFLAGS = $(AM_CFLAGS) -I$(ul_libmount_incdir)
- endif
- if BUILD_NSENTER
-diff --git a/sys-utils/unshare.c b/sys-utils/unshare.c
-index 91e0ec7..1240293 100644
---- a/sys-utils/unshare.c
-+++ b/sys-utils/unshare.c
-@@ -27,6 +27,9 @@
- #include <sys/wait.h>
- #include <sys/mount.h>
-+/* we only need some defines missing in sys/mount.h, no libmount linkage */
-+#include <libmount.h>
-+
- #include "nls.h"
- #include "c.h"
- #include "closestream.h"
--- 
-1.9.0
-
diff --git a/package/util-linux/util-linux-004-c.h-define-mkostemp-for-older-version-of-uClibc.patch b/package/util-linux/util-linux-004-c.h-define-mkostemp-for-older-version-of-uClibc.patch
deleted file mode 100644 (file)
index 0dfe7be..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-From 42a84250fc78bae3e885ecd1379e713663fe6487 Mon Sep 17 00:00:00 2001
-From: Romain Naour <romain.naour@openwide.fr>
-Date: Sun, 6 Apr 2014 12:12:41 +0200
-Subject: [PATCH 1/1] c.h: define mkostemp for older version of uClibc
-
-Signed-off-by: Romain Naour <romain.naour@openwide.fr>
----
- configure.ac |  2 ++
- include/c.h  | 14 ++++++++++++++
- 2 files changed, 16 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index 35a1f26..a9b8d34 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -321,6 +321,8 @@ AC_CHECK_FUNCS([ \
- ])
- AC_FUNC_FSEEKO
-+AC_CHECK_FUNCS([mkostemp])
-+
- AC_CHECK_FUNCS([openat fstatat unlinkat], [have_openat=yes], [have_openat=no])
- AC_CHECK_FUNCS([ioperm iopl], [have_io=yes])
-diff --git a/include/c.h b/include/c.h
-index 4a9bf3d..1b880ed 100644
---- a/include/c.h
-+++ b/include/c.h
-@@ -300,4 +300,18 @@ static inline int usleep(useconds_t usec)
- # define SEEK_HOLE    4
- #endif
-+/*
-+ * mkostemp() may be missing with older version of uClibc
-+ */
-+#ifndef HAVE_MKOSTEMP
-+static inline int mkostemp(char *template, int flags)
-+{
-+      int fd;
-+      fd = mkstemp(template);
-+      if (flags & O_CLOEXEC && fd >= 0)
-+              fcntl(fd, F_SETFD, FD_CLOEXEC);
-+      return fd;
-+}
-+#endif
-+
- #endif /* UTIL_LINUX_C_H */
--- 
-1.9.0
-
index 4b8f731ff3f48a04095777f4467424bcbba3f5b2..811d8ac7c4658c5703c2bd380df3bcf65bf3d853 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-UTIL_LINUX_VERSION = $(UTIL_LINUX_VERSION_MAJOR).1
+UTIL_LINUX_VERSION = $(UTIL_LINUX_VERSION_MAJOR).2
 UTIL_LINUX_VERSION_MAJOR = 2.24
 UTIL_LINUX_SOURCE = util-linux-$(UTIL_LINUX_VERSION).tar.xz
 UTIL_LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/util-linux/v$(UTIL_LINUX_VERSION_MAJOR)